Roon > Chromecast Stalling

New to Roon since mid December. Something broke this morning…

  • Roon used daily for 2 months without issue, until this morning
  • Fast Windows 10 i7 box with ample memory
  • No library, only Tidal and Quobuz streaming
  • Chord Mojo for headphones works OK
  • System output works OK
  • All 4 Chromecast devices are now stalling every few seconds
  • One Chomecast Ultra is wired Cat 6, others are wifi
  • Quobuz directly to any Chromecast works OK

Are there logs I can access to debug this? @support

Hi @Bill_Wolff,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Are these devices grouped? Does the same behavior occur if you play to each individually?

Since experiencing this issue have you tried rebooting your Core machine and Chromecast devices?

Verizon FIOS Gigabit network with wireless access point, hard wired throughout house.

Roon Server is wired directly to the Verizon router/wifi.

I tried rebooting the Chromecast Ultra but no change.

No grouping used yet.

Chromecast devices are used constantly for YouTubeTV, Netflix, Hulu, and other services without issue.

Chromecast devices are working from Quobuz Win64 App and Tidal web player.

Why would I need to reboot the Windows Server? I stopped the Roon program and it looks like all associated services stop as well.

I am an IT guy/developer so network and server issues are my forte. Show me the logs!

Reboot everything.

Well, I tried that before your response and a reboot of the server solved the problem. Please explain what services are running in the background that would benefit from a restart. Isn’t there a way to restart that set of services without a full reboot???

Two things:

Only people who can know what services are being used are on a need to know basis and obviously you don’t need to know. :smile:

If they tell you then they will have to…

I manage 800 production servers and they only get rebooted in maintenance windows with change control documentation. The answer can’t just be REBOOT!

I’m not an IT professional so please excuse my ignorance but I thought the solution to all computer and network problems was to REBOOT! :grin:

1 Like


There are logs. I run my Roon Core on Ubuntu, not Windows, and the logs wind up in /var/opt/roon/. I’d check the services panel on Windows.

Just to be a bit more complete, the services I see running are:

roon      1244  0.0  0.1 571484 43428 ?        Sl   Feb05   0:55 /opt/roon/RoonServer/RoonMono/bin/RoonServer --debug --gc=sgen --server RoonServer.exe
roon      1295  5.2  4.1 6877036 1366808 ?     Sl   Feb05 994:40 /opt/roon/RoonServer/RoonMono/bin/RoonAppliance --debug --gc=sgen --server RoonAppliance.exe -watchdogport=44479
roon      1302  0.0  0.0   8088  1196 ?        S    Feb05   0:00 /opt/roon/RoonServer/Server/processreaper 1295
roon      1644  0.0  0.0 929232 32212 ?        Sl   Feb05   3:01 /opt/roon/RoonServer/RoonMono/bin/RAATServer --debug --gc=sgen --server RAATServer.exe

I found the logs here:


There are 3 running executables:

Console Windows Host (no clue what is running inside this)

They don’t seem to use standard Windows Event Logs at all. They just write to a text log.

Probably so it runs on Mac and Linux.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.