Roon client only connects after windows reboot on server


Dear Roon team,

I have a problem with one of my roon clients for some time now.

The client (Windows 10, Roon 64-bit) only connects to the server (Windows 10, Roon Server 64-bit), if I start the client before the server.

As soon as I close Roon on the client side and try to restart it, the client isn’t able to connect to the Server any more.
In the client Roon window I can see, that the client is trying to initialize the connection, but then shows the error message ‘connection failed’. This happens again and again.

As soon as I reboot the server (complete windows reboot, not only restarting Roon server), the client is successful in connecting to the server again.

This only happens with one of my clients, other clients (e.g. Windows 32bit, iPhone) are connecting without any problems.

Do you have any advice for me, how to solve this problem?

Thanks and regards,


Notebook Core i7-3520M, 8GB
Windows 10 (newest release)
Roon Server 64bit, latest version
Music collection on Synology NAS, 2800 albums

Desktop Core i7-3770K, 16GB
Windows 10 (newest release)
Roon 64bit, latest version

Thanks for reaching out, @Matty!

May I ask that you please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Do you have any active antivirus or firewall on either of the machines? If so, does temporarily disabling them yield any changes?


Hi Dylan,

thanks for your response.

My network architecture is as follows:

As a central component I’m using a Netgear-GS724Tv3 switch.
The affected roon components are directly connected to the switch via Gigabit ethernet.

Additionally I have a Fritz Box 7490 as a WiFi Rooter, which is also directly connected to the switch.

I connect my other roon clients (iPhone, Samsung S5, Microsoft Surface 3) via this Wifi Rooter to the roon network. This works without any problems.

I installed roon on another computer and connected it directly to the switch, this computer also does not work.

Connecting the Microsoft Surface via docking station and GBit ethernet directly to the switch however works.

Disabling the firewalls was one of the first things I tried, without any success.

I even tried to replace the switch by another one, without any positive result.

Perhaps I should mention, that I can see the connection attempts in the logfile of the Roon server.
So there is a kind of initial communication between client and server, however it fails in etablishing a proper connection.

Beside other entries I can see something like that:

08/18 19:12:37 Warn: [MC-1.2 USB 2.0] [raatclient] RAAT Session timed out during initialization
08/18 19:12:37 Trace: [raatserver] [MC-1.2 USB 2.0] client connection failed. Retrying in 1687ms
08/18 19:12:38 Warn: [RME HDSP 9632] [raatclient] RAAT Session timed out during initialization
08/18 19:12:38 Trace: [raatserver] [RME HDSP 9632] client connection failed. Retrying in 1687ms

I hope that helps.
Thank you very much for your support!


P.S. The connection used to work previosly. Unfortunately I do not know all the changes, which I made on my systems since then.

Hi Dylan,

this is to let you know, that I decided to reset windows on my server and this reset solved my problems.
Obviously something had gone wrong in the windows configuration on my server.

No further help is needed (for the time being :grinning:).

Thanks again for your support!


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.