Roon client won't connect anymore. Help

Nothing has changed in my setup, network, NAS and laptop but all of a sudden my Roon client software (Windows 10 Pro) won’t connect to my Roon Core (QNAP NAS).

It shows the Core and when I select it just sits on the connecting animated icon. Then after some time shows the text with the info that it is taking longer than expected.

What steps can I take to get this working again?

I presume you have rebooted everything?

NAS, laptop, router, switch. Still the same.

Literally all other devices on my network are working fine, including broadcast devices (Chromecast, Sonos etc.)

Also tried from a desktop computer on the same switch as the NAS. Still the same issue, stays on the animated Roon icon suggesting it is connecting but never makes it…

Hi @Phillip_McMahon,

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Can you confirm that all of your remotes and the Core are updated to the most recent version of Roon?

Was there a Windows Update recently? Also, I’d double check the firewall settings.

Even stranger, not both Roon clients are prompting me for my account login details, and both come back with a network connection error after timing out.

I keep persisting and it seems to get me back to the select Roon core screen, I select my only core and back to the waiting at the animate roon icon until it times out.

I can pull whatever logs and share.

In terms of network I have simplified this down to a computer and NAS connected via the same switch. I run Pihole to filter outbound DNS with a standard block list (it all worked with this before) and that is about it.

Can you remove the dns filter and see what happens.

DNS filter disabled (much to my annoyance as this affects my whole otherwise working network) and still no difference.

I have stripped everything back, wired NAS and PC to the same switch, once I get passed the repeated request for Roon login details I am still stuck in this forever connecting loop.

I removed the server and deleted the database on my NAS, also uninstalled the client installs.

Reinstalled all, logged in at the prompt, now I am getting a Roon server connection error. Clearly something somewhere is corrupted/not working.

Roon support - please assist.

Just loops in a “Connecting - Initialising - Connection Failed” cycle.

From the Roon app log

2/24 09:27:52 Info: [brokerclient] connecting to homeStorage (187e8508-3563-45f1-85e4-d1085650759a) @ (attempt 6/6)
02/24 09:27:52 Trace: [push] restarting connection (Unable to read data from the transport connection: A blocking operation was interrupted by a call to WSACancelBlockingCall.)
02/24 09:27:52 Trace: [push] retrying connection in 28192ms
02/24 09:27:53 Debug: [brokerclient] auth with homeStorage (187e8508-3563-45f1-85e4-d1085650759a): Attempting to authenticate with no PIN
02/24 09:27:53 Trace: SENT REQUEST DistributedBroker.ConnectRequest={ ClientBrokerId=e7a19ab9-95b2-4ff1-9473-d309e0328724 ClientBrokerName=‘HOMENUC’ ProtocolVersion=‘25’ ProtocolHash=‘119bdb7dc8c0fa93150d0b98e2ca4db9151f9f21’ }
02/24 09:27:53 Trace: GOT NONFINAL DistributedBroker.ConnectResponse={ BrokerId=187e8508-3563-45f1-85e4-d1085650759a BrokerName=‘homeStorage’ }
02/24 09:27:53 Trace: GOT NONFINAL DistributedBroker.UpdatesChangedResponse={ IsSupported=True WasJustUpdated=False Status=‘UpToDate’ HasChangeLog=False CurrentVersion={ MachineValue=100600401 DisplayValue=‘1.6 (build 401) stable’ Branch=‘stable’ } }
02/24 09:27:53 Trace: [brokerclient] connected to homeStorage (187e8508-3563-45f1-85e4-d1085650759a)
02/24 09:27:53 Info: [brokerclient] Connection dropped: homeStorage (187e8508-3563-45f1-85e4-d1085650759a) @
02/24 09:27:53 Warn: [brokerclient] connection lasted only 690.7106ms–not good.
02/24 09:27:54 Info: [brokerclient] connecting to homeStorage (187e8508-3563-45f1-85e4-d1085650759a) @ (attempt 6/6)
02/24 09:27:54 Info: [stats] 5330mb Virtual, 222mb Physical, 34mb Managed, 4413 Handles, 55 Threads
02/24 09:27:55 Trace: [brokerclient] connect error: No connection could be made because the target machine actively refused it
02/24 09:27:59 Info: [distributedbroker] LOST BROKER homeStorage (187e8508-3563-45f1-85e4-d1085650759a)

Just doing an explicit @support

1 Like

Hello @Phillip_McMahon,

Have you tried a different Ethernet cable for your QNAP yet? Does this behavior affect just the Windows 10 Remote or do you have other Remotes that you can verify this issue with (Android/iOS?).

Sometimes Ethernet cables go bad over time so I would just like to eliminate this as a possible source of failure. Also, are you able to use the QNAP management software to access it? Are there any errors or hardware failures reported on the QCenter App?


My NAS is also running an nginx reverse proxy, Plex, qemby, subsonic and the file share for my home network via Active Directory. All working perfectly fine, it is not a faulty cable or I’d expect to see all other services with error.

All clients are affected, Android and 2x Windows (1 laptop with wifi and 1 desktop with ethernet on the same switch as the NAS). The latest errors in the log suggest something isn’t quite right with the server component.

Has there been a QNAP update recently? I have had an issue with the firewall on my Synology NAS in the past, so the NAS security config is worth checking IMO.

Really not a thing. The last firmware update was November/December time, before I had even looked at Roon.

The only change I can think of is that I enabled DNSSEC on my network, that has since been removed (as a precaution while I get this resolved) and with the exception of Roon I have zero issues with services on my network which included a whole of broadcast and direct connection types.

Dylan - please see the rest of the thread. Still not working and need some formal technical assistance please.


please could you lend some assistance, I still have this issue and as such it renders my Roon setup useless.

Hi @Phillip_McMahon,

I’d like to propose a test that should provide some additional information here. This type of behavior often stems from one of two things — Either something on the NAS is interfering with the remotes’ ability to connect to the Core, or there are networking difficulties at play preventing this.

Can you temporarily use a different machine as your Core, connected to the network the same way as the NAS? If the remotes can connect to this Core, then we know that something specific to the NAS is preventing the connection. If the remotes can’t connect, then we know this is a networking related issue.

Please give this test a try and let us know how it goes!

Tried that and all works. I unauthorised my setup on the NAS, installed on a desktop PC attached to the same switch and tried a client running on another home PC. Connects fine…

I assume this means all looks reasonable from a network perspective and points fingers at the software running on the NAS… I am not aware of any firewall or network filtering on the QNAP and have not installed anything any such functionality.

Let me know next steps for helping pin down the issue.