Roon clients not connecting after update (running v1.8, build 931)

Roon Core Machine

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.3 LTS
Release: 20.04
Codename: focal

Networking Gear & Setup Details

Google Nest Wifi

Connected Audio Devices

Windows Client
Android Client
Web Client

Number of Tracks in Library


Description of Issue

After the recent update, my clients are all stuck in “Looking for your Roon Core” or “Waiting for Remote Core …”

The server logs don’t show much:

04/12 22:39:32 Info: Starting RoonServer v1.8 (build 931) stable on linuxx64
04/12 22:39:32 Trace: [roondns] loaded 17 last-known-good entries
04/12 22:39:32 Trace: Checking if we are already running
04/12 22:39:32 Warn: get lock file path: /tmp/.rnsems0-roon
04/12 22:39:32 Trace: Nope, we are the only one running
04/12 22:39:32 Info: Is 64 bit? True
04/12 22:39:32 Info: Command Line Argument: -watchdogport=34027
04/12 22:39:32 Trace: [realtime] fetching time from NTP server
04/12 22:39:32 Trace: [ipaddresses] enumerating addresses
04/12 22:39:32 Trace: [ipaddresses]    FOUND   lo
04/12 22:39:32 Trace: [ipaddresses]    SKIPPED eno1: no ipv4
04/12 22:39:32 Trace: [ipaddresses]    FOUND   wlp0s20f3
04/12 22:39:33 Trace: [realtime] Got time from NTP: 4/12/2022 8:39:33 PM (3858784773035ms)
04/12 22:39:33 Trace: [realtime] Updated clock skew to -00:00:00.0024804 (-2.4804ms)
04/12 22:39:33 Info: [stats] 24762mb Virtual, 804mb Physical, 519mb Managed, 93 Handles, 32 Threads
04/12 22:39:48 Info: [stats] 24948mb Virtual, 6647mb Physical, 5309mb Managed, 93 Handles, 32 Thread

This was after the automatic update. I tried system restarts and manual updates afterwards.

Please help.

I note that you are using Wi-Fi only; there’s no connection on the embedded Ethernet interface. Have you tried restarting your router and networking devices?

Tried network restart, no luck.

Are you able to connect your core device using ethernet?

1 Like

Is the subnet correct?

I can SSH into my box, for example to manually install an update. May I ask why you try to further investigate the network as a potential source of the issue? There have been no regressions or changes to the network setup and other services like Plex run fine from this server, like before.

A process of elimination. What’s the output of systemctl status roonserver?

$ systemctl status roonserver
● roonserver.service - RoonServer
     Loaded: loaded (/etc/systemd/system/roonserver.service; enabled; vendor preset: enabled)
     Active: active (running) since Tue 2022-04-12 22:38:09 CEST; 1 day 8h ago
   Main PID: 5668 (
      Tasks: 53 (limit: 9112)
     Memory: 6.7G
     CGroup: /system.slice/roonserver.service
             ├─  5668 /bin/bash /opt/RoonServer/
             ├─  5672 /opt/RoonServer/RoonDotnet/RoonServer RoonServer.dll
             ├─284104 /opt/RoonServer/RoonDotnet/RoonAppliance RoonAppliance.dll -watchdogport=34027
             └─284105 /opt/RoonServer/Server/processreaper 284104

Apr 14 06:50:31 media-pc[5672]: Started
Apr 14 06:50:34 media-pc[5672]: Not responding
Apr 14 06:50:49 media-pc[5672]: 01 days, 08:12:39.268 Debug: PathForResource, filename: ../.update
Apr 14 06:50:49 media-pc[5672]: 01 days, 08:12:39.268 Debug: PathForResource, candidate: /opt/RoonServer/Server/../.update
Apr 14 06:50:49 media-pc[5672]: Error
Apr 14 06:50:51 media-pc[5672]: 01 days, 08:12:41.269 Debug: PathForResource, filename: ../Appliance/RoonAppliance
Apr 14 06:50:51 media-pc[5672]: Initializing
Apr 14 06:50:51 media-pc[5672]: 01 days, 08:12:41.269 Debug: PathForResource, candidate: /opt/RoonServer/Server/../Appliance/RoonAppliance
Apr 14 06:50:51 media-pc[5672]: Started
Apr 14 06:50:54 media-pc[5672]: Not responding

No changes on my end, but Roon works again. I would really love to understand why as I haven’t changed anything in my network, on the box that runs Roon or with Roon itself. And it’s super annoying that there are no insights into what might be wrong while I kept paying without Roon working for me. I wish Roon would invest in better, more visible debugging tooling support.

I think I’m going to hit Snooze on my Roon subscription. It’s the second time I’ve been left hanging (remember the Christmas update last year?). For a paid service, I would expect better support from humans, an acknowledgement of issues, and more in the way of “our service didn’t work? Let’s work out a way to get you back some of your money” recognition when things go wrong.


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.