Roon Connection Failures with NADAC since around time of Roon Upgrade

I have two cores (two lifetime memberships), a windows-based server (which also includes my music library) and a network-connected NADAC-Player.

After not using the NADAC for about two weeks, I could not get Roon to recognize the NADAC. This was around the time of the most recent Roon upgrade.

I have also verified that there are no firewall issues with Roon.

I had a similar problems several months ago that was eventually resolved by getting NADAC support folks to get the NADAC to serve as a Core.

Prior to that, the NADAC was a Zone with the Core residing in the Server. There was a significant improvement in sound quality when the NADAC became a Core.

I tried several things before reaching out to Roon. First, I reinstalled the NADAC firmware. When that did not make any difference, I re-set the NADAC to Factory Default and installed the most recent Maintenance Mode and Firmware. When that did not work, I re-installed Roon on my server. I have not been able to re-install Roon on the NADAC (and do not know where to find the modified version of Roon to do that with).

At this point, the windows server is working well with my other DAC (usb-connected, DAVE) and numerous zones. It is not “seeing” the NADAC.

When I was using the windows server Core only, the NADAC never showed up in my OS as part of the Network (in Mac Finder). When the NADAC was functioning as a CORE, it did appear as part of the Network.

Sounds like a dodgy nadac.

Hi @John_Roberts,

I would reach out to NADAC again as they would be in the best position to address why it is not showing up any longer.

Perhaps you can pose this question to them and they can advise. Do let me know how it goes!

I sent them a message a week ago and have not heard back from them. Probably sheltering in place like the rest of us.

I am also not able to access Roon from my iPhone or iPads. I get the message “Choose your Roon Core” and see the icon with “Looking for your Roon Core.”

Since the windows server Core is operating (from the Server only), I would think that the Roon app would be operational. I have uninstalled and reinstalled the Roon app several times without any change.

I have alse pressed “Help” and “Configure Roon OS devices on your network.” In the case of help, I get a screen asking for an IP address. I have provided the NADAC and Windows Server IP addresses and it gets stuck with the same message – “looking for your Roon Core.”

I have also tried to Configure Roon OS and it gets stuck with, “Searching for devices.”

Do you think this is due to the same problem?

Have you rebooted everything including your network equipment? If not start there.

I did reboot everything, including network equipment and NADAC. No change.

Hi @John_Roberts,

I can’t help out too much on the NADAC Core front, that’s a question best for the NADAC team, but we can certainly take a look at why your Windows RoonServer is not working properly.

Have you made any changes to your network setup recently? Are the Windows Core and the iOS devices still on the same network (you’re not perhaps on LTE on the iOS)?

If you have a backup of your Roon database, you may want to try installing it fresh:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Reinstall RoonServer from our Downloads Page to generate a new Roon database folder

I would also verify that you have set the appropriate firewall, as sometimes you may need to reconfigure the firewall following a Roon reinstall:

Since you are using a Windows PC, I would verify that both Roon.exe, RoonServer.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.

Hi John,
Have you tried re-installing the NADAC Operating System and then restarting the Roon server software in your NADAC Player? You’ll need to access its maintenance webpage via its IP address within your network, see below:

Good luck!


1 Like

Ruben –

This is an excellent suggestion.

I have not been able to access the screen you provided a shot of. Please provide details on how to access it.

I have reinstalled NADAC OS, now with 2 operating systems (Windows Home Server 2013 and Windows 10 Pro). I can access the maintenance screen with the information your screen shot shows. I am able to get the remote screen.

How do you get the screen that shows whether Roon is installed?


Hi John,
You’re welcome. To access the control window of your NADAC PLAYER, you have to know your NADAC’s IP address within your network, then go to a computer that is in the same network as your NADAC, type the address on a web browser (I use Google Chrome), and voilà you are at the NADAC control screen now.

If you don’t know your NADAC IP address, go to the Roon settings menu and under general the info related to your NADAC Roon core should show w/ its associated IP address, see below:

Happy listening!


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.