Roon connectivity issue

Antipodes EX server
Version 1.8 (build 778) stable

Orbi satellite
connected to server via ethernet

Denafrips Ares II
USB connection

Trying to trouble shoot an issue that started a few months ago (it may have coincided with Roon update at the time not sure about this but worth a mention).

I use one of two different Android devices to control Roon through the app, the issue presents itself on both devices. My issue is Roon is not connecting automatically whenever I open the app for the first time to start a listening session. I have to restart my server to gain connectivity, once the server is switched off and on it will connect no problem. Once connected it is usually stable I can close the app and reopen and connectivity is ok. I have made no changes to any internet settings, have rebooted the server and have uninstalled and reinstalled the app on both devices but this has not fixed the issue.

Thanks in advance for any help.

You are not on the latest version 790 or am I missing something

May not make any difference?

Do you have the same issue if you use the desktop app? The Android app has had some issue with the 1.8 release. There are a few posts about this already.

Sorry, my mistake.
This was taken from an earlier screenshot, am running 790.

Ok thanks, I hadn’t used the desktop app but have now downloaded it and it is working fine.
I assume this means the issue is with the mobile app and several others have reported the same problem?

Do you happen to have any managed switches in your wired local network? Roon uses IP multicast for device discovery. Some Android devices and managed switches don’t work well together for IP multicast. Playing around with IGMP snooping and proxying settings in managed switches and routers can help. This has been a hard-to-diagnose issue for several years with some Android devices and network configurations. In my case, I solved it by turning off IGMP snooping in a managed Netgear switch. Later, I got rid of those switches altogether. Never any issues since in multiple Pixel models.

Hi - no managed switches on our network but thanks anyway.

I’m fairly sure now the issue presented itself around the time of the 1.8 update, everything was working fine up until around this time and nothing else on my network has changed.
I’ve not done anything about it since as the workaround is fairly simple but can someone confirm if this is being worked on and if another update due is due to fix this issue?