Roon Consistently Loses Control of Device in 1-3 mins after Build 943 Update

Roon Core Machine

Roon Nucleus version 1.8 (build 943) with 2000GB, Samsung SSD 860 44% of 1848 GB available
Remote - Macbook Air, Roon version 1.8 (build 943)

Networking Gear & Setup Details

Fiber Optic cable into Axon C4000 series modem, Core connected via ethernet

Connected Audio Devices

Naim Uniti Atom via wifi

Number of Tracks in Library

Music Library is 49K tracks

Description of Issue

System has worked perfectly for a year and with the build 943 update, Roon now loses control of the device consistently between 1 - 3 min after starting. My system is essentially unusable. Have rebooted Server Software and Nucleus. System status says all is ‘OK’.
Any suggestions on what I can do to get up and running again?

1 Like

@Bryant_Bainbridge the Nucleus is intended for continuous operation. Do you switch off the device every day? Then it will indeed take a few minutes until everything is ready for operation. This not only affects the database, but also the connection to services and devices. In the course of other improvements, it can take a few seconds longer here.

No the Nucleus is on continuously.

As I mentioned, this configuration has worked flawlessly for a year and it has been only since the latest update that it has started crashing

is this helpful?

Hey thanks Uwe, but this is not the issue. It will not even stream radio. Roon does not seem to care what I am playing the results are the same - Lost Control

I can stream radio outside of the Roon interface no problem

It could very well be a WiFi issues, as a test try plugging the Naim in via ethernet and see if the problem still occurs.

Disclaimer: fellow user here

Tried that but it not the issue. I have very fast fiber optic service with very complete coverage. The Naim unit streams perfectly outside of the Roon app. Of course nothing is 100% certain, but the issues began with the last update (943) and it would seem that the issue lies there.

Same problem since last update. Cocktail device lose connection after a few minutes. Everything works fine until 943 update.

1 Like

I’m not an IT professional, but what I’ve read on the Internet and here on the forum suggests that good system settings are needed in addition to good hardware.

Some internet providers don’t seem to be strong enough to provide stable name resolution, which is why this help page was set up. Some have had success with it. I’m currently testing if my slowness problem with my default DNS will really slow down or maybe even speed up.

Perhaps an expert can confirm that unreliable name resolutions tangentially affect audio components.

Also, it is recommended to remove IPv6 from the router, computer, actually all devices that should work reliably with Roon. This is curious, because it is generally assumed in the limited address space of the Internet that it will continue to run reliably only with this newer protocol. The following improvements are mentioned:

IPv6 offers the following improvements over IPv4:

More efficient routing without packet fragmentation.
Built-in Quality of Service (QoS) that distinguishes delay-sensitive packets
Elimination of NAT to expand address space from 32 to 128 bits
Built-in network layer security (IPsec)
Stateless address autoconfiguration for easier network management
Improved header structure with less processing overhead


Thanks for your thoughts but were this the case I would have expected issues long ago, but my issues are entirely coincident with the 943 update on a system that functioned perfectly prior to the update. And with fiber cable speed is not an issue in my house.

1 Like

I can confirm it here.
Roon sometimes loose my audio device on my Roon core (Mac) during my audio session. I am very disappointing. The DAC ifi micro idsd black label is connected as usual to Roon and at least one time per day Roon says that I have no audio device connected. After some seconds the DAC is found again. Before the last three updates I had had no problem with my DAC. First I thought that the DAC is defect but if I use it within the Qobuz app on my Mac directly I have no trouble with my device.


I´ve tried the DNS Change but the problem still persist. After a few minutes the device diseappear and after a few seconds it reappears. This goes on and on. Sometimes it works for 5 minutes, sometiemes for 3 or only a few seconds. The problem is since update to Version 943. Hat vielleicht auch jemand das Problem aus Deutschland?

Yes, I´m from Germany. Mostly it works again for a hour or so after reconnecting/reappearing.

Hallo Frank, sieht aber wirklich nach einem Problem der Roon Firmware aus. Ich teste gerade standalone und dort läut alles normal.

Hi From Germany,

I use a ROCK based Roon core and devices directly connected to the core (hdmi) and a DAC connected to my iMac all running 943.

I just learned about this by this thread. So far I don’t have any issues. But I will keep an eye on this

After uncheck the ip6 Protocol it works fine for an hour, but now it stops again.

I´m afraid it is a bug of Roon software and we must be very patient. I don´t know whether the developers see this post.

I’m also working here right now without IPv6 and with Google DNS instead of my provider’s, but it’s all up in the air again at the moment.

If not even the overview for The Commodores comes, is about not functional. It takes minutes until a title is played or repeated and only the second attempt delivers my local library without further details from the network.

second try

but not playing but waiting waiting waiting…

With Foobar2000 I have more fun

third try

It is obvious to me that Roon gets into overload situations and then delivers such ugly performance pictures.

1 Like