Roon constantly drops the connection

Used to be: MacBook Pro, 2012 13". Now: MacBook Pro, 14". 12.9" iPad Pro. iPhone SE.

ASUS Blue Cave, a couple network switches

PS Audio DirectStream DAC

248660 tracks

I’ve got that computer that Roon used to recommend, an Intel NUC, in a closet with a bunch of drives, wired to my PS Audio DirectStream DAC. I operate it from a Mac via wireless.

For the last couple months it’s constantly dropping the connection. It just did it twice. For about half-an-hour. I go to play something, open up Roon or touch the mousepad, and WHAM! Connection dropped, trying to connect. When it comes up, I try again and it drops again.

In the middle of having this problem I changed my computer, still have the problem. On my iPad and iPhone, same problem.

Hey @Dan_Schwartz thanks for reaching out to us as soon as you experienced this.

Could you share more about how everything is connected? You stated that you have some switches in your networking setup - are you using these switches to connect the Core and audio endpoints? Can you attempt to hardwire the Core directly to the router? Is there any improvement?


Possibly, yes. But before I try that, which may mess with my set-up, let’s think this through. It was rock stable for about a year. Nothing seemingly changed a couple months ago - except maybe a Roon update.

If I take the switches out, we may or may not find any improvement, as the problem - which is a REAL problem - is intermittent.

@Dan_Schwartz Thank you for sharing. It’s understandable that this may not be a viable solution, however, in our troubleshooting, we think it’s best to first simplify the network connections to see if we can pinpoint where the issue is occurring. This would only be as a test.

As an additional note, have you yet tried to reboot all devices within your setup? You’ll want to reboot the Core, all remotes, and the router by powering them down, unplugging them (those that can be unplugged) for a few minutes, plugging them back in, and powering them back on.

Okay, I’ll attend to all of this in the morning. Right now I’ve bypassed the switch at the NUC end.

1 Like

In the last week, I’ve had to take my whole system down. (We’re replacing our floors throughout the house.) So I’m using a Node 2 into a PS Strata amp in the bedroom. Right now, the system can’t connect with Roon. It hung up for about 15 minutes, appeared to be connecting, and instantly dropped it again. There is only the modem, router, and the NUC carrying Roon. Nothing else is connected.

Bumpity bump bump bump

Bump bumpbumpbumo

bump ducking bump

Bump Bumo Bump.

Thee must be a reason thia is being ignored/

Looks like Ashley has left Roon.

@support will hopefully be in touch with you in the week as they do not work weekends.
It does seem to have been waiting a while :scream_cat:

Yes, over 3 months. Still happrens.

Hi @Dan_Schwartz,

First off, we’re terribly sorry that this message went without a response for so long. For context, there was a mistake reassigning this thread internally after some personnel changes on our team. That’s no excuse for you having to wait so long. I apologize for the strain on your patience, as I know how frustrating it is to bump a thread multiple times and hear only echoes.

We’ll absolutely pin down and resolve the connectivity issue you’ve been experiencing.

First off, did the Core reboot you performed in this other thread resolve anything with the connectivity issue you’ve been experiencing?

It will help to know some current details of your network, so I do apologize if you’ve provided some of this information previously.

Which network switches you were using (make and model)? Would you please also provide the model number of your router?

Do you have a firewall enabled on your Mac?

Let me know, and I’ll be closely watching for your response. We’ll follow up with additional troubleshooting steps and proceed from there.

@connor, @support
No, the connectivity issues still go on.
Network switch: Netgear G530v2
Router Asus Blue Cave
Firewall: No
None of these were new purchases when the problems began. It had all been working fine for months.
Nonetheless, the issues have just gotten worse. It tried to connect yesterday for literally hours.

I thought that employment thing might be THE thing.

Hi @Dan_Schwartz,

We’ve gone through diagnostic reports from your device and I have a few suggestions before we proceed with additional steps. There’s a chance this will resolve the problem - which I recognize is painfully overdue at this point - but regardless, it should stabilize your setup and create replicable conditions so we can pin down what’s wrong.

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Do you have a Watched Folder in Roon which is on an external hard drive? If the above steps don’t work, it will be helpful to see your watched folders by providing a screenshot of your Settings → Storage page.

You’ve endured an arduous and undeserved experience after your initial post slipped through the cracks on our end. I’ll follow up first thing after the weekend to verify if the database reset from the above steps worked.

You can see that my drives are connected to the NUC but for some reason late last year their names disappeared. There are 6 of them.

It’s doing something new. Now it gives me a warning just befor4 it loses the connection. A circle gradually draws itself and then the following shows up. After about 15-20 seconds this appears:

I think the picture above isn’t what you asked for. This is: