Roon constantly stalls apparently while loading thumbnails

I got a strange one. I puilled out an PC that I used to run Roon on a few months ago; The PC I used for a Roon Remote had died and I wanted to use this as a replacement.

So plugged in got it going; everything fine. Roon working perfectly as a remote.

But Windows 10 was not happy and spent 10 hours downloading the latest version of windows 10, the creator update.

(Note while windows was downloading this, Roon worked fine).

So after the big Win 10 update, Roon behaves very oddly. Starts fine but does not show cd thumbnails, at least not initially. Takes about 30 secs for each one to load.

Go to say Artists and you see a bunch of blanks. Wait about a minute and they load. While they are loading program is unresponsive. But go to next page and the same hangup occurs. While it’s loading thumbnails the program is basically hung and doesn’t respond to input. Once the artwork has loaded, you can scroll back and forward thru artist pages just fine, until you hit one that has not loaded it’s image. Then it hangs again.

Some things to note:

  1. The Roon core that this remote is talking to works just fine with other remotes, running on ipad, win7 and win10
  2. There is almost zero cpu, disk or network use during the hung periods. (So it’s not hung up waiting for CPU)
  3. I removed Roon and it’s database (on this PC) and reinstalled. Same problem
  4. I’m an windows programmer so I don’t think I’ve done anything stupid.
  5. The PC is a fanless and slow PC, celeron j1900. But it’s run roon core in the past just fine. Now I just wanted remote.

Just wondering if anyone’s seen this type of thing. This PC was only going to be temp until a newer one arrives.

Hi Bob,

You don’t mention your graphics card but you are describing an interaction effect between embedded intel 4500 drivers, openGL and roon64bit.

This issue is long unresolved, but If you are just using the laptop as a remote, try installing roon 32bit. It gets a bit more complicated if you are using the laptop as a core and you have a largish library greater than about 100k tracks. In that case you will need to install both a 64bit core and a 32bit remote.

Thanks that fixed it. Strange that it worked OK until the latest windows 10 version. I already have the “blank screen following minimize” issue on that PC, but it’s a temp thing until the new one arrives.

Glad to hear it. BTW it was probably Windows 10 updating the graphics driver that broke roon. Another workaround is to rollback the graphics driver and/or block Windows updates. But that just causes a lot of other problems.