Roon Control on Windows 7 - update failed

Core Machine (Operating system/System info/Roon build number)
Roon version 1.7 build 610
Windows 7 64-bit
i7 16GB RAM
GeForce GTX 660 Ti

Description Of Issue

Hi, hopefully someone can help me. Whist viewing the Control on my Windows 7 machine I’ve had a prompt to update Roon (blue update box at bottom of screen), I’m assuming for Core & Control & Output. My Core is hosted on this machine. Whilst the Server is now on the latest version the Control update has failed - I get the usual music quote splash screen but now followed by a black blank screen:

Core is ok as I can still access that from an iPad remote (1.7 build 571) and can output music from the Windows host. What should I do next? How do I install Roon Control back on my Windows machine which is my main ‘work bench’ for handling my music files & meta data?

One thing that may be causing a problem is I appear to have both ‘Roon’ and ‘RoonServer’ on my machine, probably due to my confusion during the initial trial install. RoonServer has been updated a day earlier, from an iPad remore prompt I think.

Thanks in advance, Simon

Hi @xxx, thanks for your help so far. I must’ve got myself in a muddle a couple of years ago when I first auditioned Roon, installing both ‘Roon Server‘ (core+output) and the ‘Roon’ suite (control+core+output) on my Windows host. As for still running Windows 7, I know, I’m running a risk. Anyway, I’ve worked out my ‘Core’ was from the ‘Roon Server’ installation so have now uninstalled the Roon suite. So far, so good. So my next question is, how do I reintroduce Roon Control on my 64-bit Widows host whilst still retaining all my Roon settings? I have Roon backed up to separate storage discs. Does a backup contain all ‘system’ setting as well as those associated with my music collection?

I have similar. First did remote software update. Then the ipad (remote) does not find the Nucleus. Go to home PC (win7 64bit), open Roon app and get asked to perform update.

I perform update.
Screen then is blank. Cry…
Shut down Windows PC and restart.
Turn off Nucleus+ (power removed); turn back on Nucleus.
Open Roon app on Windows PC - still blank.

Go back to iPad - still unable to find Roon Nucleus.

Use iPhone - it can see the Nucleus and play through… so I guess that is hope…

But I need the Windows app fixed. And I need to use the dedicated iPad so need to figure out if have to reinstall the Roon controller app on the iPad…

Hi @support, so what I had here was ‘Roon’ (control+core+output) and Roon Server (core+output) simultaneously running on my 64-bit Windows 7 platform. It was a mistake that I installed both Roon & Roon Server during my original Roon audition a couple of years back, but it’s worked perfectly well since then. My core, via Roon Server, has updated correctly to ‘1.7 (build 610) stable’ but the Control update has failed leaving me with a blank screen. I’ve since deleted ‘Roon’ from my host, losing the ‘failed’ Control element but Core and Output via ‘Roon Server’ are fine, as confirmed using an iPad Remote.

My question now is, how do I reintroduce Roon Control on my 64-bit Widows host whilst still retaining all my Roon Core & Output settings? I have Roon backed up to separate storage discs. Does a backup contain all ‘system’ setting as well as those associated with my music collection? So it’s ‘how do I add Control to my Windows PC without having to install everything from scratch?’. Has my explanation made sense? Happy to provide more info if requested - Thanks, Simon

1 Like

Hi @support,

I’m really at a loss here, I need your help. Control on Windows 7 64-bit worked fine for 1.7 build 571 but will not update to 1.7 build 610 - the quote splash screen opens followed by a blank (black) window with ‘Roon’ and the logo in the top left corner (see screenshot earlier in this thread). I’ve tried removing & reinstalling ‘Roon’ (control+core+output) for the ‘Control’ component for both 32 & 64-bit Windows versions but get the same outcome, so it’s a case of my setup worked fine for ~two years up to Fridays build 610 update. My ‘Core’ is derived from ‘Roon Server’ (core+output) which resides on the same machine and has updated successfully to build 610. I’ve explained earlier in the thread why I’m running both ‘Roon’ & ‘Roon Server’ on the same machine - it will have been down to me not understanding the architecture when I first auditioned Roon but I’ve left it like that as I’ve experienced no problems with the setup since, up until yeaterday.

I really need a fix for this, the Windows machine is my ‘work bench’ where I’ve spent many hours curating my music collection, other devices are simply playback remotes. BTW, I have a lifetime subscription, so this means a lot to me.

Thanks for your help in advance,

This is most likely not an issue with server running and is more likely a graphics drivers issue with roon remote as your iOS devices can see the core no issues.

It’s a weekend. I would recommend you don’t go removing anything right now and just wait for support to assist you or at least update your graphics drivers. What Roon version are you on before it upgraded?

Hi @wizardofoz, it will have been the upgrade from build 571 to 610 over the last 24 hrs. Never had a problem with ‘Control’ on Windows 64-bit up to that point and I always update when prompted. I’ll try upgrading my Nvidia graphics drivers but something has imo changed between the last two Windows Roon build releases. Thanks, Simon

Running both roon server as core and roon as remote is not an issue -I’ve done it for years on both macs and windows setups. Removing server without knowing you have successfully tested backups to restore is in my mind a bad thing to do right now.

1 Like

Hi @Jim_F, thanks for your comments, I understand that I don’t need ‘Roon’ & ‘Roon Server’ on the same Windows machine, but it’s how I set it up originally, albeit perhaps incorrectly, it’s worked fine since.

Hi @wizardofoz, I do have backups on separate USB drives, in fact I ran a restore yesterday in the vain hope that it might solve my problem, sadly unsuccessful. My worry here is eventually having to do a complete rebuild from scratch. Does the db backup include system settings as well as the music library metadata? I remember at the time taking an age to figure out how to get a pure signal from from my Windows ‘Output’ (wasapi I think) which I wouldn’t remember how to replicate now…

I understand that. I’m just looking forward toward a solution. You can keep both on your computer if you want and if you can get them both updated properly. Or, you can delete the one you don’t need. But, I would wait for Roon Support.

So really, no matter what the outcome is as far as ‘successfully testing’ a backup (however one could be able to do that), that horse left the barn yesterday.

At this point he might as well delete (better yet rename) everything and start fresh with just Roon and a library restore.

I’m out of this thread.

You aren’t running 2 monitors by any chance are you?

No, single monitor, nothing out of the ordinary

The update is probably fine, problem is highly likely to be related to hardware or drivers that are not able to support some GUI tweaks or features in the new update. This is common for older hardware and os versions unfortunately. Full open GL V3 is needed, maybe you can do some googling for your hardware support of this spec

@support will no doubt be along soon to assist but again given it’s a weekend give them some time to get to your issue in their queue.

1 Like

Hi @wizardofoz, thanks for help so far. My card is an Nvidia GeForce GTX 660 Ti - their spec sheet states OpenGL 4.3 - I’ll update the drivers next. Simon

Great news @wizardofoz & all the other contributors to this thread - A graphics driver update has allowed me to restore a working Roon Control (build 610) back on my Windows workstation. Thanks again, Simon


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.