Roon controller loses connection to Nucleus

For some time now when connecting to the Nucleus via the controller on a MacBook to a Bluesound Node the connection keeps dropping. Either Roon tells me it has trouble connecting to the core or more frustratingly playback suddenly stops then skips several tracks before resuming then I of course have to go back to where the tracks started skipping and resume playing from there.

Netgear Nighthawk Router
Nucleus 8721 tracks
Netgear extender
Controller on MacBook
Bluesound Node 2

Low and behold as I was typing this it just happened again at 17:20 local time. According to the diagnostics on the Node there is an excellent signal from the extender and looking at the controller track in the Queue informs me it is playing but the status bar is not moving. Roon is telling me it has lost control of the audio device!. Hit the pause button then play playback then resumes.

Not sure whether connecting via an extender is the problem or not?.

Yes, WiFi-extenders are problematic.
Let’s say you have an access point on one side of your house and an extender on the opposite side, next to your Roon endpoint. So the signal from the extender to your endpoint is very strong (good bandwidth), but how’s the signal from the access point to the extender? If it where good, you haven’t bought an extender (so it’s bad, low bandwidth). So the low bandwidth between the access point and the extender is the best what you can get, no matter how good the bandwidth between the extender and it’s connected clients may be. If the extender operates in a single band only (2.4 or 5 GHz) then the actual bandwidth gets even halved because of the repeating of the signals between access point, extender and client.

If you really need to use an extender, make sure to place it somewhere in the middle where the signal from the access point is still in a mediocre range.

It would be much better if you could use two wired access points (pricey business solution; network knowledge needed) or a mesh setup (cheaper consumer solution; Google WiFi and the likes).


Hi @Terry_Fell1,

I would agree with @BlackJack’s assessment here, it is possible that your range extender is too far away from the main router and is causing these types of issues. As a simple test, you can try connecting the Node 2 via Ethernet to the primary router and verify if things work as expected then. If it does, this means the issue is between the router -> extender connection.


Hi and thank you for your input.

Will move the extender to the hallway about halfway between the router and Node however have tried this before. The result of this being could not get an excellent signal from the Node ( Problematic to stream Hi-Res files ). As you can see from the screenshot ( Music Room ) it is using the 5Ghz to connect to the router and then 2.4Ghz to the Node and this may not help the situation!. The other extender ( Pulse 2 ) is no way near as flakey as the Music Room with it plugged in the bedroom as far away as you can get from the router but as you can see it is only 2.4Ghz.

The sad truth is, that the manufacturers have commercial interests and thus don’t tell the truth about these products. :frowning:
If you were only interested in checking your e-mails and surfing the net, you can actually gain a little more range (but by far not as much as manufacturers will make you believe). But if you want to use it to stream videos and high-res music the demands for a stable and high bandwidth connection actually requires a placement so close to each other - it’s just ridiculous.

Both of your pictures show an excellent connection to your access point. If this were the truth, the best advice I could give you is to get rid off the extenders as they are just not needed.

Picture 1 shows a single band (2.4 GHz) range extender. The 300 Mbps represents the maximum speed of the radio cell - which you can achieve under good environmental conditions (no or minimal pollution through other radios on the same frequency), close to the router and direct line of sight. I assume that this is not the case at the current position of the extender. As I also noted in my first post, as of the single band usage the actual speed gets halved (hence the mention of “up to 145 Mbps”). The actual throughput can not even be reasonably estimated on the basis of this picture.

Same scheme for the connection to the access point for picture 2.
This is a more advanced product that operates as cross band extender (2.4 GHz and 5GHz) - so no halving occurs (maximum achievable speed 300 Mbps under optimal conditions as stated above).

As the law of physics dictate, the 5GHz band allows for higher speed at the cost of shorter range compared to the 2.4 GHz band. The 5 GHz band is also much more sensitive to reflection / absorption effects (people moving around, open versus closed doors or windows) which can lead to great differences in the connection quality. In it’s current configuration, where the 5 GHz band is used to connect to the access point this might lead to an unstable connection.
As of the better range and stability of the 2.4 GHz band I would suggest to switch the two bands so the 2.4 GHz band is used to connect to the access point and the 5 GHz band is used for the clients. This should considerably increase the perceived quality. There’s a good chance that a relocation to a place nearer to the access point is no longer needed.


I appreciate your feedback.

Moved the Extender to a more central position but sadly was still getting the same problem. Decided to connect the Node 2 directly to the router but diagnostics in the settings was showing a poor signal, so moved the Node to be more in line of sight of the router. The signal level moved to Good but after playing just a few tracks the same problem occurred :unamused:. After checking the signal again in the Node 2 the signal had dropped too poor/moderate so for some reason the wireless signal seems to be temperamental. Do not really understand why as anything else connected to the router wirelessly works flawlessly all over the bungalow. Considering the Node 2 is no more than about 25 feet away from the router it is puzzling to say the least. Have now decided to draw a line under this issue and have now connected to an Audiolab M-DAC via usb max 24bit/96.0khz using a Roon controller on my MacBook ( So far so good ). Probably try to sell the Node 2 on in the near future as someone else may have better luck setting up and using?. Modern technology eh :joy:.

Hi @Terry_Fell1,

If the Node 2 was reporting low signal while right next to the router, I’m thinking that it still might have been connected to the extender and not the primary router unit.

I don’t know how you’re connecting your Node 2 to the extenders, but if there is an Ethernet port available on the extender you might want to give that a shot.

Either way, sorry that you couldn’t resolve the issue with the Node 2 in this configuration, if you want to move on and are happy with the M-Dac just let me know and I can close this thread.


Hi noris,

Seems there are more things going on with regard to Wi-Fi issues?, And may need to apologise to Bluesound as it seems it is not entirely the fault of the Node.

Yesterday spent hours looking on several community web sites regarding issues many have with their Wi-Fi. One thing was clear it is a very complex subject and not as straight forward as people think.

During this time a few people recommended an app called " WiFi Explorer Lite " for OSX. Downloaded the app and when running it opened my eyes to what is actually happening during the streaming process. So with this in mind using both Extenders to my Bluesound products will take screen shots to show just what is going and why. May well post my findings on this forum bearing in mind I am no expert. Could well be a case of " Don’t shoot the messenger ".

Thank you for your patience and support.



Since setting the extender in the bedroom to channel 1 away from any possible interference seems ok. For some reason also the Node 2 connected to the other extender ( 2.4GHz ) is also playing ball with no dropouts so far!!!. Not sure wether it is because everything else is connected via ethernet or 5GHz with no chance of interference but happy days. :smile:

This post could well be the " The Kiss Of Death " though. :thinking:


Hello @Terry_Fell1,

Glad to hear the good news and that you were able to switch the channel for your extender and things are working as expected now! I’m going to go ahead and mark your post as [Solved], but thanks again for contacting us and I hope you have a continued enjoyable Roon experience!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.