Roon core 1.6 on Exasound Playpoint PP1 not working

Dear @support

Large music lib on NAS (6,6 TB).
Roon core on Exasound Playpoint 1 connected over USB to e38 multichannel DAC. Remote on iPhone and iPad. All network connections are wired 1Gbps but obviously remotes use wifi.

I’m no longer to use roon with my exasound PP1. It was working fine when it suddenly no longer could become stable. It was around the time when Roon 1.6 became available but PP1 was still on 1.5, I have been able to get control for a very short time a few times and successfully upgraded PP1 to 1.6 but it didn’t help.
On power cycle of PP1 it shows ready for a short while and then initializing until it no longer responds. If I connect while it’s ready, the iPad never finishes updating library (i.e. showing the animated Roon icon) and eventually loses connection.
Not really sure how to proceed. I could install Core on a Win 10 pro computer that I recently bought, but don’t know if I could get my curated library onto it. Have spent quite some time to fix album matching etc.
I’ve power cycled PP1 many times. Most recently on Feb 2nd 16:34 UTC in case you can connect to it as I’ve seen you’ve done for various issues. I will likely continue to reset it to try to gain control.

Hello @Daniel_Enochsson,

I’m enabling diagnostics on your account. What this means is that the next time your Playpoint connects to the internet, a package containing advanced logging will be uploaded to the Roon support servers. Can you please reboot the Playpoint to get the system into a functional state long enough for the logs to be sent? I will be sure to let you know if they are successfully uploaded.


Excellent. I just rebooted it. Hopefully it will work for long enough…

Hello @Daniel_Enochsson,

The logs were received on our support servers. I’m passing them along to the QA team for further analysis.


1 Like

Are the apps on any control devices similarly updated to Roon version 1.6?

Yes, they are. Should also mention I have tried to setup ropieee for a 2ch USB DAC and I have roon bridge on my new Win10 computer. Still connected on the network. I also have a roon remote on my macbook.
Btw, the e38 is currently connected to w10 and used for jriver. Long term plan is to possibly decommission the playpoint and run Roon core on the w10 box, outputting multichannel to e38 and jplay to my nice 2ch rig.

I’m curious if there has been any progress and if there is anything I can do to assist the troubleshooting? For what it’s worth, I have quite a bit more (non-related) equipment connected to the network (mostly wired connections), such as computers, media players, Philips Hue control, Logitech Harmony remote hub, etc. etc.

Hello @Daniel_Enochsson,

We have been looking at your logs as well as our in-house playpoint for clues as to what may be occurring here. The ticket is still being investigated, I hope we will have something to share later today. Thanks for your patience and understanding.


Thanks for the update :slight_smile:
I work with customer support and know the advantage of having a reproducible fault so I’m sure we’ll find out what’s going on eventually. It’s frustrating not being able to use Roon for the moment but I’ll be patient.

Hello @Daniel_Enochsson,

After taking a look at the logs, the tech team believes this may have something to do with your network share or storage locations. Are you using a USB attached drive or network share for your music storage? Would it be possible to either disconnect (in case of usb) or power off (in case of network share) the storage device and then rebooting the Playpoint?

Should this not work, it will likely be necessary to reach out to Exasound support. Something is causing the device to crash during the Roon startup process, which is why you are unable to connect to the device. Since the Playpoint is managed by the Exasound operating system, any further troubleshooting would have to be performed with their assistance.


1 Like

That was spot on @john,
With power turned off to my NAS, the playpoint came up stable but without a music library. Of course Roon without a music lib isn’t much fun so I turned on the NAS again and after a while it showed the library. However a few minutes later it became unreachable again.
But with this method I am able to do some troubleshooting on my own. I have separated the library in different directories - hirez, dsd, lossless and lossy so I can disable various parts and test what the offensive part is. I can also move parts of the library to a different location and narrow in on what it is. Since this gives me a good way forward I am marking the issue as solved even if it’s not actually resolved yet. If I’m not able to get it working I think it’s better to open a new ticket since I will be having more info by then. Thanks a lot to you and the tech team.

Btw, I’m thinking it may be related to capacity of the playpoint when my library has grown and it would feel much better to have roon core on a computer. In particular since I don’t use the gui on playpoint anyway and I could get recover some money by selling it. My follow-up question is how to do that without losing my edits (mostly helping roon find the correct match)? I realize I should follow the instructions in this link to do the actual move:
But then I expect the playpoint must be stable with my full music lib. Where are my edits saved? Is it possible to successfully run the backup and retain the edits even with disabled shares on the playpoint? In that case I could try moving roon core to a computer. Other suggestions on how to deploy a computer based roon core while keeping my edits are much appreciated.


Hello @Daniel_Enochsson,

Your edits are saved in your Roon database, which is included with your hopefully regularly scheduled “Roon Backups”. You may be safe to plug a USB storage device into the unit and try and add it as a backup location. I would talk to the support team over at Exasound to find the best option for you.


My testing indicates that it’s not a specific file that is locking up the playpoint. It will hang when I add a number of music locations and when I change to other locations it will also hang.

The backup sounds promising but… it seems I have ran into the backup part of this issue:

Problem above is seen regardless if I try to backup to USB or network share with write access for everyone. (NAS is an 18 TB ReadyNAS 428.)

Also do you know if the backup will contain edits for disabled locations or do I first have to get it stable with my complete lib before I can backup and change to a computer based Roon core?

Looks like it’s time to involve Exasound support too.

Thanks for your support this far, it’s much appreciated.

@john, I’ve taken down the solution flag so I can inform others of what my contact with exasound will lead to, once they’ve worked out what the issues are. I hope we can solve both original issue and failing backups with the help of exasound and then other playpoint owners will benefit from it.

1 Like

Hi Daniel,

The USB drives attached to the PlayPoint are accessed in read-only mode. This is by design, to preserve the integrity of the data in case of power loss or accidental disconnect. It is possible to enable read/write access with a firmware update. We have to think about it.

Regarding backups in remote NAS storage, there is noting special with the PlayPoints. We use a standard Roon Core and it should work with network shared storage.

Thanks @George_Klissarov,
The thread I quoted in post 14 mentions problems even when choosing a NAS as backup directory and likewise I have the same issue directing the backup to my NAS.

We will do more testing to try to recreate the problem.

Me and George will continue over email, but once we have a conclusion me or him will update this thread.

We will release a firmware update next week to fix the issue of Roon backups on attached USB drives.