Roon core 1.7 with multiple AirPlay not working

Core Machine (Operating system/System info/Roon build number)

Mac OSX Catalina (10.15.1) with 32 GB RAM
Roon version 1.7 (build 505)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

All running on wifi, devices about 20m spread apart

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

  • iMac itself that’s hosting roon - works fine. Data is also all hosted on an external drive here, but I’ve also setup Tidal and using live radio functionality
  • AppleTV close by, works fine as expected
  • Marantz receiver (where the AppleTV is hooked up on) also streams fine through Airplay
  • Sonos one (duo) in the kitchen is doing nothing, while trying to play it shortly changes to a pause button, then goes back to be a play button. Reset of routers, sonos’ and roon (host) didn’t work.
  • Apple homepod in the bathroom, play button turns into a pause button, but time doesn’t proceed.

Description Of Issue

  • AppleTV works

  • Marantz receiver works

  • sonos one doesn’t work

  • homepod doesn’t work

  • Tried both local flac, wav and mp3 files

  • Tried tidal files

  • Tried live radio

All scenarios have the same outcome, as described above.

I’ve tried grouping up several devices as well, but all I get is device from the AppleTV or receiver.

So the purpose of Roon (controlling multiple audio streams on different devices through one interface) is defeated, audio works fine on the devices by the way.

Thanks for the support!

Hi @Kees_Romkes,

Welcome to the forum. Can you please provide some more information regarding your network setup? What is the model/manufacturer of all your networking gear? Is your Core connected to the same router or access point as the Sonos/Homepod (note, not just on the same network, but the same access point)?

Hi Noris, thanks for responding - I’m full on Google wifi, so meshed. Three access points, the roon server (imac) on the same as the devices that do play, the other devices are on the other access points.

Unfortunately I need to keep this setup, I can’t remove two of the access points for various reasons. What would you suggest?

Hi @Kees_Romkes,

If you temporarily connect one of the devices that don’t work to the same access point (referencing as APs moving forward) as the other 3 that do work, does that resolve the issue? This is a test, and not meant to be the solution, but would be a great data point.

If this does resolve it, I have a few follow-up suggestions:

  1. Conform that both APs are operating in the same subnet range (e.g. The IP addresses it assigns have the same IP except for the last 3 digits 192.169.1.XXX)

  2. Verify that multicast routing is enabled on all of the APs

  3. Try rebooting the networking gear, starting from the primary router to the APs

I’ll try moving one of the devices to meet the same access point as the roon server, but it defeats the purpose of it all I’m afraid.

  1. Yes all are in 192.168.86.x as is standard on Google wifi setups
  2. Multicast is not supported by Google wifi (although some internet threads tell different stories)
  3. Done, no changes there.

Is EERO supported by Roon?

Hi @Kees_Romkes,

This is just a temporary test that would provide us a good data point. There must be something different regarding these two nodes, I’m certain we have others with a similar Google Mesh setup to yours with no issues, so my thinking here is to eliminate the access point from the equation.

I can’t comment on specific compatibility, but I have seen other customers mention they have Eero and Roon works for them. Although I wouldn’t discredit your current setup without performing the above test of having all on one access point. This might just be a mis-configuration issue somewhere along the line.

  1. I’ll move the homepod to the same network
  2. I’ve changed the sonos one to work through sonos itself, instead of airplay - they work fine that way (but of course can’t be grouped anymore)

I’m considering ROON for the long run, not have to have a solution today, and replacing Google with EERO in the future is an option (don’t like their nest and voice integrations)

Thanks for your patience @noris, I’ve been playing around a bit and still couldn’t get it to work. But now I do!

So the problem here comes from the ‘homepod’ setup, apparantly changing the settings to match the solution to this problem:

Also made it so that the sonos speakers in the kitchen now work through airplay too, and creating a group through airplay is now also enabled.

It’s curious that the ‘allow speaker access’ in the home setup is also attached to the sonos’, but not to the receiver end. Could be that the receiver doesn’t do the check if a device is allowed to use it or not, anyway.

Thanks for your patience Noris, hopefully this response will also help others with a google wifi / airplay combination setup!

1 Like

Hi @Kees_Romkes,

Glad to hear you were able to resolve the issue with that setting turned on!
If you have further issue please do feel free to reach out again to us!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.