Roon Core 1.8 (1126) not giving option to upgrade to 2.0

Roon Core Machine

HP Envy running Windows 10 build 19044

Networking Gear & Setup Details

Running a normal WiFi network. Core, Remotes all connected to the same WiFi SSID.

Connected Audio Devices

Linn Select DSM

Description of Issue

My Roon core on Windows laptop loads normally with version 1.8 (build 1126). I am able play songs using the desktop client. My remote clients on iPhone and iPad got updated to version 2.0 However, the core is still running 1.8. I clicked on About under settings and it shows I have the latest version installed. I tried changing the updated options to all three types. But my core still thinks it is running the latest version.
Since the Remote software have been updated to version 2.0 they no more can connect to Core running 1.8. Please help.

Don’t know the root cause for your problem, but likely downloading current version from Roon and just installing it on top after pulling a database backup helps?

And just as an unrelated side note, other potential problems may arise from connecting your core wirelessly, see Roon’s knowledgebase here.

Thank you. I tried to go the Roon Download page and logged in to my account. Both the Windows Download and Mac Download icons are not active (they show up as just labels). Only the Free download label is active. Can I please be given a link to download?

Build 1126 is the new legacy build… So you won’t be prompted to upgrade. Did you change over to 1.8 Legacy?

Upgrading back to 2.0 can be done if you follow this:

How do I move to Roon 2.0 from Roon 1.8?

When you’re ready to move to Roon 2.0, make sure to follow these steps:

  1. Completely close out of Roon / RoonServer

  2. Download the appropriate installer for your Core from the links below

  3. Install and run

Download Links for Roon Core 2.0:

MacOS All-in-one / MacOS Remote

MacOS RoonServer

Windows All-in-one / Windows Remote

Windows RoonServer

Linux RoonServer Install Script (Instructions)
ASUSTOR RoonServer (Instructions)
QNAP RoonServer (Instructions)
Synology (DSM7) (Instructions)
Synology (DSM6) (Instructions)

1 Like

Thank you. I downloaded the Core software and reinstalled. It was successful and I did not have to restore the database as it did not wipe out the database contents.

Clicked on Roon Arc under settings and it failed to configure it. It did manage to add an entry into my router firewall to enable port 55000 to my Roon Core IP Address.

As part of troubleshooting, I disabled the McAfee firewall on my laptop running the Core, and Roon ARC showed ready status. I could run Roon ARC successfully on my remote devices and play music.

As a permanent fix, I enabled the McAfee Firewall and inserted a rule to allow port 55000 for all IPs and now I am able to use RoonARC with the McAfee firewall running.

Once again, thank you for your support.

1 Like

Excellent news!!!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.