Roon Core cannot be located on Synology 218+

Roon Core

Synology 218+, DSM Ver. 7.1-42661, CPU: Intel Celeron J3355; Total Physical Memory: 10GB; Roon installed version 2022216; Roon Core on external SanDisk USB with 114.58 GB available and 1.42 used.

Networking Gear & Setup Details

Network connected to Synology via ethernet. Router is Deco (TP-Link) running ver 2.12.9.
Other network connected devices working fine.

Connected Audio Devices

First Roon endpoint is a Yamaha RX-A 2050 Receiver connected via ethernet.
Second is a Windows 11 PC connected via ethernet and then via HDMI to a Sony Receiver.
Third endpoint is a Denon receiver, also connected via ethernet to the network.
I also have Roku which I don’t use.
I access Roon via the Windows 11 PC, a Windows 10 PC, and an iPhone SE, none of which can find the core.

Number of Tracks in Library

Somewhat less than 10,000 tracks. All still accessible via PLEX.

Description of Issue

When trying to run Roon from two of my PCs and an iPhone, it is unable to find the Roon core. Everything worked perfectly last week, and had been working for several months, but now it doesn’t work at all. I have made no changes to my computer or NAS in that time. I tried uninstalling and reinstalling Roon (with the 2022216 version) but no changes. The Synology is working fine, and I am able to access all files, and access files including the music files via PLEX, but not Roon. Looking at the Package Center, Roon is installed and running. But I just can’t access the core.


Hi James, I’m not from support, just another user trying to help out. This sound like it might be an IP address issue as Plex and accessing files can work over SMB. A couple of ideas/suggestions:

Have you tried a reboot of your router and a shutdown/restart of your DS?

How is your Synology’s network interface configured?

Ideally, you want it set to Get network configuration automatically (DHCP):

It would also be ideal if you could set up a DHCP reservation for the Synology in your router. Then it will always have the same IP address assigned to it every time the lease renews.

Not support here too. Some routers have a dedicated guest network port (mine has). Was something changed on the router’s config or the cabling? Asking since this fool here managed to put his mobile on the guest WLAN and kept wondering for hours.

@James_Burling, I agree with Graeme, this sounds like an IP address issue. Take a look at the IP address of your Synology 218+ and compare it to either of your PCs or your iPhone. In order for these devices to talk to one another the first three blocks of numbers need to be the same. For example, two devices with the following addresses can talk to one another:

192.168.68.xxx
192.168.68.xxx

Whereas these two cannot:

192.168.1.xxx
192.168.0.xxx

I appreciate the ideas. I’ve had an address reservation for the Synology for quite some time, and the address hasn’t changed. And the address remains within the range for 192.168.0.xxx. That’s been the case for at least six months. I did try rebooting the router twice, but it made no difference. I’ve rebooted the DS several times since this started happening, and it makes no difference. More significantly (I think) I have no trouble accessing the files on the DS from my computers or my phones, remotely or locally. I haven’t touched any cables for quite some time, nor have I touched the guest network settings. So, I remain stumped and unable to access the Roon core.

And, for the sake of completeness to my responses, no I’m not trying to access Roon or the DS from a guest network. I know from experience that doesn’t work (yeah, I’ve made the same mistake in the past.)

And you did not add VMM / vSwitch recently? Possible source of headache in this combination.

Thanks, but no, and I do not have an understanding of what a VMM / vSwitch is so I’m pretty sure that’s not it. In any event, my network interface simply shows the LAN connection that I’ve used for many months. Nothing has changed so far as I can tell and I’m not in the habit of messing with network settings.

Hi James

DSM 7.1 is new (I just installed it today), and it may have altered permissions on the folders which house the core. As I run Roon core separate from the NAS, I can’t help in isolating which folder you would need to check permissions on.

Thanks. The permissions on the drive and the roon core folder are all set to read/write.

It sounds like you had the same issue I did on my 415+. No changes to network topology and my NAS has had a static LAN IP for years.

I got impatient last night and uninstalled the Roon package, deleted the RoonServer folder on the external SSD that is reserved for RoonOnNAS, and reinstalled Roon. Before that, however, I installed the latest DSM updates (it seems you have to manually download / install the latest one(s). Note, I keep Roon backups in a different folder so those didn’t get deleted. However, I didn’t restore any of them and just let Roon re-analyze 15k tracks over night. But all said and done, everything is working again. So, worst case, it seems that will likely work. Allowing the Support folks to pinpoint the issue is probably a better long-term strategy though.

James, just one more thought - when did you switch up to DSM 7?

I installed 7.0 quite some time ago, shortly after it came out. And I installed it before I saw the warnings that it wasn’t a good idea. Roon didn’t work as warned, and that forced me to drop my Roon subscription for a while until the new version of Roon came out that was compatible and post-Beta. I’m not sure when I went to 7.1 and whether that could be related to the problem. I just generally accept updates. But I haven’t been seeing other people complaining about 7.1 related problems, so I’m guessing that’s not it. But if others have had problems after 7.1, I’d love to know. I’m just hoping I don’t have to go the way of Prashant (above) and uninstall and reinstall everything. My time (and patience) is limited. But thanks for the question.

And I tried uninstalling once already, so I’m not even sure that will work.

7.0 and upgrade to 7.1 work here (DS1517+) - so sure no general problem.

I’ll have a look at my setup tomorrow (RS3617xs/RX1217) - I waited until the last gasp to upgrade to DSM 7.x By then, most of the issues had been resolved. There were a few specifics that had to be changed after installation to enable everything to work. I’ll refresh my memory and report back.

I bit the bullet. I uninstalled. Then removed the USB SSD and replaced it with another and reinstalled and reindexed. System now works. For now. Thanks, though, for all the ideas.