Roon core cant suddenly find my luxman Asio driver

Core Machine (Operating system/System info/Roon build number)
Intel I7 Windows PC (Windows10, 64 bit/Roon ver 1.7 build 511.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
500 Mbit ethernet Network, cabled, fully function.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Luxman DA-250 - USB connected.

Description Of Issue
My Roon core can suddenly not find my Luxman driver. It writes device initialization failed in the device box under Audio in Roon setup.

I have restarted everything and reinstalled the Luxman driver but nothing helps. How can i find the solution to fix it?

The driver works fine when i use Tidal ! but suddently not with Roon

Hi @Palle_Karlsen,

Welcome to the forum. Can you please try using a different USB cable? Sometimes I have seen reports of USB cables go bad, so it would be good to get this out of the way. Also to confirm - are other zones on this PC working as expected?

Hello Noris
The USB cable works well when i use it with Tidal from my other laptop and direct to the Luxman. The Intel PC with the Roon core installed are new and have 4 USB ports, and i have tried them all. I use the laptop and my Huawei phone as remotes for the Roon Core. Everything have worked fine until today. I have deleted the Wasapi driver from the Luxman in Roon when i installed the software a month ago, so i can not test theWasapi driver. How can i reinstall the Luxman drivers in Roon ? Can that solve the Problem ?

Hi @Palle_Karlsen,

Can you try to enable “System Output” and let me know if that works as expected?

I also want to mention one other aspect here, we have sometimes seen Realtek Drivers cause strange behavior in Roon, as noted in the following thread:

Realtek driver might be playing a part in the issue here, so if you would be willing to temporarily uninstall them, it might help clarify if they are causing such behavior.

Now it looks like this, and still dosnt work. I have after disabling restartet both computers.

Hi @Palle_Karlsen,

Let’s try setting the current Roon database and settings aside:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Find the folder that says “RAATServer”
  • Rename the “RAATTServer” folder to “RAATServer_old”
  • Reinstall the Roon App to generate a new Roon folder
  • Without restoring from a backup, verify if the behavior is the same

The libary RAATserver, RoonServer dosent allow me to change the filenames, only RoonGoer.
Roon server are not startet up. I checked with task manager. No programs were active.

Hi @Palle_Karlsen,

What do you mean you can’t change the file name? This process is for changing the Roon folder name, not any individual files, here is a quick .gif on how to do it (please perform the same for RAATServer though.

Hello again
My folders dosnt look like or are not named as yours. Mine are named Roonserver, Roongoer and Ratserver. When i rename them with the extension old, and thereafter starts Roonserver again. nothing happens.I dont know how to proceed. I use the Roonserver on a headless PC

How can i save my playlist in Roon ?. Must i delete the whole Roon installation and start from scratz again. It is very annoying and if the Problem reapear i dont think i will continue with Roon.

Hi @Palle_Karlsen,

The Backup you created in step #1 of my instructions saves your database information, simply restoring the backup or renaming the RoonServer_old back to RoonServer will get you your old database back, but we are testing to see if using a fresh one triggers a change in behavior for this test.

If you are using it headless, then yes, renaming RoonServer will get you a new database up and running.

Is the RoonServer application still running in the system task bar? RoonServer does not have a User Interface, so it must be controlled from the “All-in-one” version of Roon or another Roon Remote/Client. You may need to specify “Choose a different Core” on the Roon Client/Remote since this is essentially a “new” install.

To sum up the above:

  1. Can you check to see if RoonServer is running in the system tray?
  2. If you connect via your previous Roon client and set the system up as fresh, are the audio devices now appearing?

I have choosen the new core on my previous Roon remote client and when i had to choose an audio device the luxman device still says initialization failed

Hi @Palle_Karlsen,

Just to clarify here - are you connecting the luxman to the Core or to the Roon Remote/Client? If you are connecting it to the Roon Client, can you also set the client install aside and start it fresh using the above instructions?

Hello Noris
The Luxman are connected direct to the new Intel I7 PC via a new USB cable. This Intel Headles PC are only running Windows10 and Roon Core. I will delete the Core Roon installation and all Roon remotes and try to install it again. Are there something i must be aware of before installing it again ?

I have now reinstalled roon on headles pc and remotes and also reinstalled the luxman driver. Now it functions again. I hope the problem dosnt appear again :slight_smile:

1 Like

Hi @Palle_Karlsen,

Happy to hear that a reinstall of the Core + Remote has resolved this issue! If you have any other issues down the line feel free to reach out again.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.