Roon core disconnects often after MacOS Ventura

After upgrading MacOS to Ventura 13.1, Roon core often disconnects, especially after the current audio zone is gone. I have to touch the Roon Core in my Mac Mini so that the Roon App in iPad can see my core again.

Welcome to the Roon community, @Shuo-peng_Liao.

To receive appropriate help, it would be really helpful if you could complete the template provided below. Please be sure to include details of your core, network, storage location of your media files, and any messages displayed by Roon. Thank you.

Roon Core Machine

<!‐-Include your operating system and machine info (Model, CPU, RAM)-‐>
<!‐-Write below this line-‐>

Networking Gear & Setup Details

<!‐-Your network gear (model of routers/switches) and if on WiFi/Ethernet, are you using VPN-‐>
<!‐-Write below this line-‐>

Connected Audio Devices

<!‐-Specify what devices you’re using and their connection types, like USB/HDMI/Chromecast, etc.)-‐>
<!‐-Write below this line-‐>

Number of Tracks in Library

<!‐-Tell us how large your music library is, eg. “30,000 tracks”-‐>
<!‐-Write below this line-‐>

Description of Issue

<!-‐Tell us about the problem you’re having in as much detail as possible. Screenshots are always appreciated!-‐>
<!‐-Write below this line-‐>

Including these details in your first post helps resolve your issues faster.

I think I found the root cause. After upgrading to MacOS Ventura on my MacMini, its default power saving mode could turn the device to sleep when the display is off. And when the device go to sleep and resume, I have to touch the Roon Core application to wake the service up.

In MacOS Ventura, the System Setting had a major UI change. There’s no way to disable sleep in Power or Energy Saver tab.
To prevent the system from sleep, go to Display > Advance > Energy section: “Prevent automatic sleeping when the display is off.”

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.