Roon Core Does not See KEF LS50W on Network

Roon is not recognizing my KEF LS50W speakers on my network so they do not show up in the audio tab of setup as an audio device. I am using a laptop as my roon core (Lenovo Miix i5), which is connected wirelessly to my Orbi network. The orbi network is a main orbi and one satellite, and when Iog into my orbi network, I have both the KEF LS50Ws and the laptop running the roon core connected to the 5ghz wifi network. Roon is able to see the two apple tvs on my network as airplay devices, but the LS50Ws do not appear anywhere in the audio tab in roon. I can see the speaker on the network with my phone using the KEF streaming ios apps, so I know it is not an issue of the speakers not having a solid connection to the network. The speakers are updated to the latest firmware.

Any suggestions? Thanks!

Speakers need to be on and set for WiFi for Roon to see them

Yes, the speakers are on and connected to WiFi (hence being able to see them on the network via my router and in the KEF app, which connects over WiFi).

Roon does not see them, however. I have tried power cycling the speakers, closing and reopening Roon on the computer, uninstalling and reinstalling Roon on the computer, restarting the computer, power cycling the router and Fios modem, and redoing the kef speaker setup (basically reprogramming the speakers to the WiFi). Nothing seems to work…

I am only vaguely familiar with the Orbi wireless system. What happens if the speakers and core both connected to the same Orbi device? What I’m saying is can you ‘steer’ the speakers and core to be both connected to either the Orbi satellite or the Orbi main box?

Thanks, good suggestion. I’m not sure if there is a way to force devices to connect to one orbi device or another, but in my case both the speakers and the computer with the room core are indeed connected to the same orbi device (the main unit, not the satellite).

Hello @Sorrick,

Can you please try connecting both the Core and the KEF speakers via Ethernet to the primary Router? Even just temporarily as a test will allow us to know if we should focus more on the WiFi aspect or of there is something else that could be going wrong here.

Just to confirm, if you open the KEF Control App, the selected mode is WiFi and not anything else, correct? I would also double check that Roon is allowed past your firewall, sometimes this is a source of issues and you can use these instructions to check on Windows.


Hi Noris,

I’m just seeing your reply now, several moths later. I have my KEF speakers connected to my router via ethernet. My core is connected by wireless (computer it is on does not have an ethernet port). I’ve checked through the windows defender firewall settings and roon is allowed past the firewall, so that should not be the issue. If I connect my speakers to the computer that my core is running on by USB, roon sees them, but if the speakers is connected on the network, roon cannot see them and I do not have a way to manually tell roon to look for them (from what I can tell). Any help would be much appreciated. It is very frustrating not to be able to connect to the speakers via the network. For wha it is worth, roon can see the appletvs on my network via airplay.


Hi @Sorrick,

Can you please confirm that you are using the newest firmware on those KEF speakers? You can use the KEF Control App to check this aspect.

Is there any change in behavior if you temporarily unplug the satellite and leave just the primary Orbi unit running? Are you certain that the WiFi on the FIOS Modem is not active and the speakers or the Core are not accidentally connecting to that one instead?

– Noris

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.