Roon Core "Failed to initialize device" on X45Pro Endpoint

Core Machine (Operating system/System info/Roon build number)

Windows 10 Home Version 10.0.19041 Build 19041
ASUS GL753VE Laptop
Intel Core i7-7700HQ CPU at 2.8 GHz
16GB Memory
1TB Disk Storage
Roon Version 1.7 (Build 710) stable (64Bit)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Comcast x1 Router running at 600MbSec Model CGM4331COM
Hardwired directly to X45Pro

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Cocktail Audio X45Pro running Tidal, Music DB
Connected to Emotiva RMC-1 Pre-Amp Processor via HDMi (plus other digital and analog connection types)

Description Of Issue

The X45 Pro was installed running Tidal (HiFi) natively before connecting connecting to the Roon Core on my PC. I also downloaded the Remote Control app onto my Galaxy S8+ running attached version.

Everything worked for the first few hours after setting up Tidal in Roon including controlling the X45 from either the Core or the Remote Control app.

Later, upon starting the Roon Core after the X45Pro was already powered on no music could be played from the Endpoint, no Tidal tracks and no Music DB tracks.

I closed the Roon Core and Remote apps and the X45Pro still would not play any music, although the menu system was working fine. In order to return the X45Pro to operation I had to power it off then back on. All worked as expected until I launched the Roon Core then no music would play yet again.

I have tried launching Roon before and after powering on the X45Pro and the same result occurs.

Hi @Robert_Noakes,

Are you able to play to other devices besides the X45Pro okay?

Alternatively, if you connect the X45Pro to a different devices besides your Android remote does it work with Roon?

Hi Dylan,

The only other device is the PC Core and Tidal is playing fine natively using HDMi out. I then enabled the internal soundcard in Roon and tried playing Tidal in Roon which definitely shows me logged in to Tidal and the app will not play anything from System Output, but has the strange behavior of cycling quickly through all the tracks on an album without playing them…and returns to “Playing Nothing”

The Remote App again does the same behavior as the Core on all 3 “devices”…System Output, Realtek Audio and Intel Display Audio.

Hi @Robert_Noakes,

This sounds like symptoms of a firewall issue. Since you are using a Windows PC, I would verify that both Roon.exe and RAATServer.exe have been added as exceptions to your Windows firewall.

You can use these instructions to add the exceptions and the executables themselves would be located in your Database Location/Application folder path.

I would also add these exceptions to any Antivirus or other Firewall blocking applications you may have and ensure that you connected to your network via a Private network, not a Public one, see this guide for more information.