Roon Core Fails to Install Latest Update on Mac Mini 2014 (ref#40SS45)

Affected Product

Roon

Roon Issue Category

Installation or Setup

Description of Issue

My Roon Core is a Mac Mini 2014 vintage running Mac OS Monterey with a 2.8GHz Dual Core Intel i6 chip. The Roon software is 2.0 (build 1182), but it will not instal version 1311 which is the latest version. It downloads the update, but fails to install. As a result, I am unable to use Roon via my iPad or any other device in the house. Setting up Roon for use with my DACs and Streamers took about a week and was exceptionally painful, even though it was set up with a Stack Link2 which is a Roon certified device, so I am very reluctant to delete /uninstall the app and reinstall it. Note that I am not a computer wizz and need to keep things simple. The firewall on the Mac Mini has no restrictions. Ideas?

Roon Core Platform

macOS

Roon Core Specifications

Mac Mini 2014 vintage, Processer 2.8GHz Dual Core Intel i6 with 8MB of RAM, connected to a Stack Link2 streamer and Mojo Audio Mystique DAC.

Connected Audio Devices

Stack Audio Link 2 USB Streamer and Mojo Audio Mystique USB DAC

Home Network Details

Streamer is hard wiredand all other connections are hard wired. The house has CAT 6 cabling throughout and RJ45 connection points, so no wifi.

@Christopher_Conway, are you having Roon download the update from within Roon, or are you downloading the latest build from Roon’s download page (below):

https://roon.app/en/downloads

If the former, please make a backup of Roon’s database from within Roon, then download from the download page and install the latest release (B1324) over your current Roon installation on the 2014 mini.

Thanks for the suggestion, but I tried downloading the latest version from Roon and it would not load.

Next step was to update the OS and try again. That did result in some updating in Roon - from 1.8 to 2.0, but not to the latest version.

Hi @Christopher_Conway,

Thank you for your patience while we worked through the queue to reach your report.

We’ve examined diagnostics for the affected Mac that are available to our servers and can pinpoint several automatic update failure events. In each case, the install script ejects prior to completion despite the update having properly downloaded. However, there are network dropouts throughout diagnostic logging around the time of the update failures, affecting both your RoonServer upstream connection and the visibility of endpoints throughout your LAN via RAATServer.

We’ll first try a few steps to stabilize Roon on the Mac itself, but we’ll want to try to illuminate the network instability as well. There are two possibilities here that are not mutually exclusive: 1) network dropouts are causing a corruption of the download and 2) there’s a drive partition, hardware, or temporary file issue blocking the install script itself on the Mac.

First, please fully uninstall your Roon database by taking these steps:

  • Create a Backup of your current database
  • Exit out of Roon
  • Navigate to your Roon Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Reinstall the Roon App from our Downloads Page to generate a new Roon folder
  • Verify if the issue persists on a fresh database before restoring the backup

Next, please elaborate on the make/model of the router in your setup and any relevant network hardware in between your Mac Mini and the internet. There are instances in which Roon fails to call upstream servers for basic services like fetching the time - it’s most likely a DNS or firewall issue that we can easily resolve.

Please let us know if the above database refresh allows for the most recent version of Roon to take on the Mac. We’ll proceed from there. Thank you!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.