Roon core failure in synology NAS DS918+

I had installed the latest version of roon core (20211030) in my Synology NAS DS918+, but it is fail to activate, just appear manually shut down and shut down again and again, i tried to reboot the NAS but cannot solve this issue, any solution on this issue?

I having the same issue with the 920+. Installed in the directory try to run the DB but it shuts itself down in a few seconds

Yes, same situation no matter to restart the NAS or reinstall the Roon server, it also shut down itself repeatly.

Any solution on this issue?

@crieke Chris any thoughts here?

@Nelson_Ip @Mason what version of DSM are you running?

@Nelson_Ip @Mason
I am trying to reproduce this, but was not able to do so…

Could you provide the following info:
Did you perform the installation as an update? If yes: What version of the RoonServer app was installed before?(the DSM6 version or the DSM7-beta)?

Is your RoonServer database stored on a local shared folder or on a USB attached volume?

My install was a clean install. Was asked where the DB core file was located and the music files were located. Volume one on the 920 is were the files reside. In a attempt to insure file integrity I did unpack the spk file again and this time it did see it as an update.

Also I just been made aware of a DSM update 7.0.1-42218. I hold off on that till we get this cleared up

My older version is DSM 7-beta and should be up to date, everything is OK until i installed the latest version 20211030, and my roon data base is installed in DS918+ local shared folder.

I can confirm that DSM 7.0.1-42218 and the latest Synology Core 20211030 will not work. Unfortunately I upgraded the NAS and the Roon Core. It starts the Core, and then very shortly it shuts itself down. This was working prior to upgrading the DSM to the latest version (it was running the previous version 7).

Hi Chris,
I went through your install instructions again on your web page. One thing I noticed was in DSM there is not a drop down in Packages to select “any publisher”. You can use a manual install option. Under Packages, settings you have general, auto updates and package source.

I called Synology support to see what suggestions they could offer. They said you should see an error message if the DB stops with the “manually stop” unexpectedly.


I am new to this forum but have the same issue when I want to launch RoonServer on DSM7.
DSM version : DSM 7.0-41890
Installation file : RoonServer_Synology_DSM7_x86-64_20211030
I have noticed that the permissions for RoonServer app to access my music shared folder are always reset when I want to launch the app = read only instead of read&write.
Other issue : the roonserver database folder is empty after installation. I can only see a “bin” folder. I don’t know if it is normal. I tried to install on a USB external drive (SSD) and internal drive (HDD) and it does not make any difference.
I hope it can help.

I have identified a situation, where the database location is not set properly in the last release. I made a small change to the installer and put it on the website.

I received info by 2 users, that it does indeed resolve this issue.

Please uninstall the previous version, as the database can only be set on new installs.

I performed an uninstall and re-installed the newest version 2021105 and I am still getting the same results of starting and then immediately getting a “Manually Stopped”. Not sure if this issue that 2021105 addresses running the Roon Core on a new DSM 7.0.1-42218 install, or if I am still screwed until a later date and time. One thing that I am noticing is that when I change the permissions to read/write from read and do a save, when I then attempt to start the application it takes a little longer to fail, and it has changed the permissions back to read only. Thoughts?

The music shared folder only gets read permission by the installer. I think DSM will re-adjust it, when you change the permissions. Roon Server only needs write access to the specified database shared folder.

Can you check if there is a log file in your specified database location?
It should be in the RoonOnNAS folder and be labeled RoonOnNAS.log.txt.

I am not seeing a RoonOnNAS folder. The logs are all in a logs directory and are called RoonServer_Log.(version number) i.e. RoonServer_Log.txt. Should I uninstall the program from DSM, and then remove the folders as well, and then do a re-install?

Just wondering: Did you choose the same folder for Music and Database location during installation?

Yes, I have them all of a 1TB SSD.

Then I believe I know what’s happening: The Wizard assumed to pick different location for Music and Database location. The music location gets only read permissions, the database location gets also write permissions. I assume it resets itself to read permission.
As a datapoint, could you try to uninstall and install again with different shared folders for music and database location?

I’ll have a look at the app for a workaround in the meantime…

Ok, I will give that a try. I am out of town until Sunday, but will do it then and let you know the results.