Roon core freezing on Android and windows

Core Machine (Operating system/System info/Roon build number)
Sonictransporter roon core
Samsung S20 ultra Android 10
Windows laptop Windows 10.

Network Details (Including networking gear model/manufacturer)
Asus router RT AC 3200 eithernet to core

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Audio device to Krell Vanguard DAC and 4k foundation preamp.

Description Of Issue
Nothing is working.
Software very slow and freezing won’t respond.
Uninstalled and reinstalled nothing works.

I can log into the sonictransporter and even restart the Roon server. I’ve also rebooted the router.

Help please!

Hi @David_Engelhard,

Even after a reboot do things go right back to this slow / frozen state, or does it work normally for a while?

Were there any changes to your setup around the time this started occurring?

Hi Dylan, I’ve tried everything. I had a firmware update 2.7 to 2.8 on my Sonictransporter about 4 days ago which is the roon core as you know. However it was freezing and slow before that. Not sure you know Andrew at Sonore but his stuff has been certified by Roon for awhile. I also use Krell, As you know. Should I try using my laptop as the core to see if it makes a difference? Is been so long I’ve forgotten how. That won’t solve the problem for me but it be interesting to see if it’ll make a difference. LMK and thank you.

Same here around the time David Engelhard reported this. All of a sudden everything came to a halt. Restarting the core did not help. I’m on Qobuz (also via Roon), so maybe there was something wrong there at that moment? I tried Qobuz directly via their own app, but that went fine.

Looks like some central server e.g. Qobuz caused trouble. Does Roon address any external servers with its core, apart from the music services like Tidal or Qubuz?

Patrick roon sometimes just hangs spinning. If I does come on the screen you can’t even touch play. Doesn’t matter about qobuz or tidal i have both.
Sorry we’re in the same boat.

This would be a great test! It’s hard to say just yet where this might be stemming from, and if this doesn’t happen with the laptop it’s safe to say we need to focus on the Sonictransporter. If it does happen, though, we know the issue is a bit more broad. This will be a great data point for getting us closer to understanding the root cause.


I deleted my history of 6788 files played. Seemed to help, but it was the day after. Memory usage went back considerably. I see no reason to keep a long history. It should be possible to limit this.

My laptop made no real difference. Slightly faster. My android samung s20 ultra takes when working 4-6 minutes including looking for core finally finding it but nearly every control from roon on tidal and qobuz freezes it takes for ever. Like dial up internet also or makes no difference how close or far away from the router Asus 3200 the problem persists. I’m hoping roon is working on a fix for android 10. I think the last update ruined android and windows.
That’s when it got really bad. My core is a sonic transporter i5 recognized by fully by roon.
I really think this is a software problem.
The phone acts ok except for Roon

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.