Roon Core in Innuos Zenith not finding Tidal

Roon Core Machine

Innuos Zenith SE.

Networking Gear & Setup Details

Netgear 95/ethernet

Connected Audio Devices

Bricasti DAC/USB

Library Size


Description of Issue

New Problem since last Roon update: Tidal is not showing up on my Roon Remote in the “Browse” section (iPad, current version). All of my data is there, but “unavailable” on every track. The Zenith has worked perfectly with Roon for nearly 3years until now. The Zenith version is current. I have rebooted and checked for latest versions on all devices. I substituted a Roon Nucleus and everything functions normally, but when I tried the Zenith again as the core, Tidal is still gone.


Hello @Kenneth_Scissors,

We’re sorry to hear that you’re having difficulty accessing your Tidal content in Roon. As dedicated music fans ourselves we certainly don’t want you to be separated from your favorite music for any length of time.

Let’s start by having you check to ensure that your Tidal account is still active by logging in directly on the Tidal app or website. Occasionally payment methods associated with streaming accounts expire and customers aren’t notified. So let’s check that first.

If everything is good there, please navigate to Settings>Services>Tidal and make sure that your account is linked in Roon. If you’ve recently migrated your Core you may have been logged out of Tidal.

If neither of these efforts lead to success please let us know and we’ll continue to seek a resolution.


This topic was automatically closed after 2 days. New replies are no longer allowed.