Roon Core interruptions - Uh oh, something’s not right

Roon Core Machine

NUC 7i5BNB with 16Gb ram and 250Gb M.2 SSD
OS: Roon ROCK

Networking Gear & Setup Details

Telenet Router
Linksys LGS328C

Connected Audio Devices

Roon Core with no direct connected devices.
Interruptions happen on all playback devices

Number of Tracks in Library

172709

Description of Issue

Since a week I experience short dropouts when music is playing. This happens on multiple roon endpoints which are never playing at the same time (only one playback devide at the time)

I can successfully start the track and sometimes it stops in the mid of the first track with the message “something’s not right” or “waiting for your roon core” and then a bit later I can press start again and it continuous playing and then stops again a bit later.

This happens with playback from own library, Tidal and Internet radio.

Other network devices conncted to same router do not experience this issue.

Not sure if it’s the same issue but Roon search is also intermittently working today with the message like “Can’t connect to roon search”

@Benedikt_Gruyaert, is your NUC running ROCK, Windows, or Linux as your Roon Core? It’s possible that with a library as large as your library 8 GB of RAM may be insufficient and Roon may be running slowly.

Another area to consider is your Ethernet switch, which appears to be a Linksys 24-port managed swtich. Roon does not recommend using managed switches as the management and configuration of these switches may interfere with Roon and passing of its RAAT audio protocol. Unmanaged switches are recommended.

Is it possible to remove the NUC from that swtich and temporarily use an unmanaged switch and determine if this helps improve your problem?

Hi,

I’m running Roon ROCK. I can try to put a different switch although this switch is over 2 years in use without any issue.

I checked the memory and seems to be a 16Gb module. I’ve updated the first post with this info.

Thanks.

Have you tried re-booting the whole system from Modem - Router forward , it often helps

Yes I did, it was my first action…

I tried with a non-managed switch to no avail…

No further help after 6 days?

By now it shows a bit more stable in the playback (sometimes the tracks do not start immediately but with a delay) but have very often the error message when doing a search for album which is very recent as well.

Hi @Benedikt_Gruyaert,

Thank you for your patience while we worked through the queue to reach your inquiry.

We’ve examined diagnostics available to our servers through automatic reports from your ROCK, and there don’t appear to be classic symptoms of network instability. However, Roon is struggling to index what appears to be a large volume of tracks in your locally stored library that have the same tag applied multiple times, as well as a large volume of TIFF data stored in jpegs associated with library album art.

If you navigate to Roon → Settings → Library and select “Clean Up Library,” would you please share a screenshot of the resulting dialog window? This should give some descriptive information about how much library data Roon has cached but not yet deleted. Additionally, please elaborate on the tagging structure you’ve applied to your Roon library, as nearly every track appears to have multiple overlapping tags.

Can you please share either an approximate timestamp for when a search failed within Roon with an error popup, or the string for which you searched? We should be able to pinpoint the cause of the search failures in logs.

Search errors can often arise from address resolution issues as a result of router’s chosen DNS server. In your router web administration page, it might be worth verifying what DNS server has been assigned. Cloudflare DNS, Quad9 or Google DNS are the most reliable for most Roon users.

Lastly, it’s worth running a RAM test on the Intel machine, since broad network performance decline in the absence of specific network failures can often indicate an increasing drive failure or corruption risk.
Open-source memory stress tests like Memtest86+ are compatible with a driver for Linux64 via their website downloads.

Hi @connor,

Thanks a lot for troubleshooting and the proposed actions. I already took action to convert all tif files to jpg. Can you explain a bit more on what you mean with “every track appears to have multiple overlapping tags” ?

Hereby the screenshot after cleaning the library:

And no “Skipped Files”:

image

As for DNS server settings on my router, this is managed by my internet provider. I have the DNS configured like this in the client sofware (Roon):

image

This is the standard setting on my router:

The result of the memory test passed successfully.

Thanks

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.