Roon Core is disconnecting when streaming from Qobuz

Core Machine (Operating system/System info/Roon build number)

Merging NADAC+ Player

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

AVM Fritz Box 6890 (LTE) -Austrian Version / D-Link 16 Port unmanaged 1GB Ethernet Switch / Aqvox 8 Port 1GB Ethernet Switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

NADAC+ Player is connected via CAT 7 Ethernet Cable into the Aqvox Switch, Aqvox Switch is connected via CAT 5 Cable & Patchfield to 16Port 1GB Ethernet D-Link Switch which is connected to FritzBox 6890. WAN Connection is LTE only in Austria!

Description Of Issue

If the NADAC+ Player is working in Streaming Mode from Qobuz a “Core Disconnecting” appears from time to time without finding any pattern! After a timeframe between 10 Seconds to 5 Minutes the Core is reconnecting again and I could restart the Play Mode. I was working with AVM and Merging support on this topic but nothing could solve that issue!
Static IP Adress, turning off Hardware & SW Acceleration into AVM Router, connecting the NADAC+ Player direct into AVM Router, …
After 10 Weeks I sent back the unit to the vendor and they tested the Player with Roon & Quobuz streaming too and all is working well for 12 Days nonstop streaming!
The vendor Merging is located in Switzerland, I’m living in Austria and connected via LTE!
Do you have any ideas?
Many thanks

Hello @Ernst_Unger, and welcome to the community! Let’s try a few options.

  1. I’d like you to see if this issue happens with any input you use. And do you have issues playing directly to system output?

  2. If your switch is managed (if you’re not sure just let me know the model number) we recommend removing it temporarily to see if that helps. I’d run the core directly to the router and see if the issue still exists, we can always expand outward from there!

Hello Nuwiry,

  • This issue only happens during streaming from Qobuz!
  • What du you mean with “playing directly to system output”?
  • Both Switches are unmanaged.
  • Yes, I connected the NADAC+ Player (Core) directly to the Router (without any Switch between) and the issue appears again!

I also tried to go back to an old Modem (Alcatel) and the issue appeared too!
In that case it’s not an issue from the Router!
The courios thing is, that the Core is running in streaming mode (exactly with protocol) for 109 hours without any issues and suddenly the problem appears.
The second problem I can’t understand is that the unit is working as well in Switzerland!?
Do you have any experience with an LTE Modem in Austria with Roon and streaming mode?
Many thanks

Hello @Ernst_Unger,

By system output, I mean the default audio device built into your core. This will tell us if the problem happens directly on the core. You could try using Google or Cloudflare DNS also, this could help with the connection.

Also, I am in the United States, but I don’t think our locations play too much into this. The folks you sent your gear to could have a different ISP among other things. So let’s work at that angle and see if we get some results.

Hi Nuwriy,

O.K., I understand, tanks for clarification.
The Nadac+ Player is designed that the core is direct included into.
That means, that the failure happens directly at the core into the Nadac+ Player.

Many thanks

Hey @Ernst_Unger, could you try lowering the streaming quality from Qobuz and seeing if that still has issues playing? Also, I’d still recommend switching DNS servers and seeing if that clears things up! Let me know.

Dear Nuwriy,

to reduce the streaming quality is an easy exercise for me, will turn to CD quality.
To switch the DNS server I have to ask a friend for to support me in that case!
Will do both things and keep you informed about, but please keep patience, I have to check and try all changes for a couple of hours to ensure of it - more then 100!
Many thnaks

Hi again,

to switch the DNS Server their appears a problem!
To which IP adress I should switch?
Do you have a recommendation?

Many thanks


You might try using google’s DNS address or Cloudflare’s DNS address at

Hey @Ernst_Unger, I wanted to clarify:

  1. So you’re still having an issue after trying google and cloudflare DNS?
  2. What happened when you lowered to CD quality?

Dear all,

this issue doesn’t appear ever day and if I’m changing something (reducing streaming quality to CD) I have to watch that for a couple of hours within in minimum 5 Days ore more!
Please keep patience and let me watch some time what will happen.
If the failure (core disconnecting) will appear after reducing streaming quality to CD, I will try the next step and switching the DNS Server to Google,
Are you agreeing on that steps?
Many thanks

Hy again,

after lowering the streaming quality and starting playing the core crash appears again after 17 Minutes of streaming from Qobuz in CD quality!
I now have changed the DNS Server to google and will let you keep informed whats going on…
Many thanks


Hi Nuwriy,

after changing the DNS Server and had a testrun the unfortunately the issue happend again!
That means, both suggestions (lowering streaming quality from Qubuz & changing the DNS Server) didn’t solve that issue.

Hi @Ernst_Unger,

Since things are not working even with low quality, it would seem like there are two potential issues here:

  1. The Core machine is having trouble streaming this content
  2. The network is not up to the task of streaming content to Roon

Since we know that the Core machine worked on a different network when the manufacturer did some testing, the most likely cause of this issue is the network. We generally don’t recommend using LTE networks with Roon, so it’s definitely a likely cause of the issue.

There’s always the chance that there is something between the Core machine and the network causing an issue, so trying a different Core machine might be worth a shot, but ultimately it seems like the network just isn’t up to the task here. Streaming content in Roon tends to be more demanding than streaming via a streaming service directly, so even if playback outside of Roon is working okay it’s definitely possible that there could still be issues here.

I’m sorry I don’t have better news for you here, Ernst. I definitely recommend trying a different Core temporarily as a test, and we’ll be interested to hear how that works, but ultimately this is looking like it might be the network. If you have any questions please let us know!

Hi Dylan,

many thanks for this interesting answer!
I tried indeed a different core (into my Fujitsu Lifebook) and it was running as well for 71 hours!
But, the problem is, that the NADAC+ Player was playing without any issues for 109 hours…!
You might imagine, that it’s not easy to get a technical statement to that issue.
The Merging guys are extremly supportive and they took back my Player and have sent me on for testing.
But after a period of a couple of hours the same issue appeard!
The curios thing is, that there is not to figure out any regularity when this issue appears.
My unit is running as well in Switzerland streaming from Qobuz & Tidal too for 2 weeks non stop!
As you wrote, it seems that it might be an issue from LTE!
What would you suggest?
I have the possibility to request a DSL line, but due to a destroyed cable it’s not easy to get it into my house, but if it’s worth, I would try that!?
Thanks a lot


Hi @Ernst_Unger,

It’s interesting to know that another Core machine worked for some time. Is it still working if you switch back to that Core? Have you used it recently? I know the NADAC also worked fine for some time, but knowing whether or not the other Core exhibits this issue now that the NADAC is would be a great data point.

Hy Dylan, interesting point, will try to switch the core again into my Laptop and will run it there for a while. Will keep you informed about! Many thanks! Cheers, Ernst

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.