Roon core locks up when attempting to play local music

Roon core server running on Synology NAS 918+. Streams Qobuz without a hitch, but when attempting to play local music (stored on the NAS and “seen” by Roon) the remotes indicate the music is playing … but it is not. The timer does not advance.

Then I can not go back to any streaming from Qobuz. I need to reboot the core at which point I can access streaming again, but as soon as I try to access local music it all fails again.

I determine it must be Roon somehow because BluOS can stream from Qobuz AND play the local files on the NAS thru the exact same system.

I’m not sure the specs of the 918+ are sufficient to run Roon without issue.

From Roon Help: “To get a faster, more reliable Roon experience, we recommend moving away from networked file systems in favor of local storage.”

Thanks for the help, but suggesting I spend $2K to resolve the issue is not really a solution for me just yet. Other systems (like BluOS) have zero issue playing NAS stored music. I would think that Roon “should” be able to do this as well.

FWIW I run on a 918+ on a docker container just fine. Everything is snappy, with the exception of search which “jumps” a lot more than when I ran off a NUC. I don’t have an answer to your question, but I run a sizable local library (35k tracks) + Tidal + Qobuz, and I run all off spinning disks with no SSDs involved internal or external and it just works fine.

I have a NUC handy, and when I get frustrated with responsiveness I’ll get it going again, but for now my experiment with running on a container has kept me happy.

I have 8 BluOS endpoints that have no issue streaming from my NAS either. However Roon differs significantly from BluOS. 2K isn’t necessary to run a dedicated Roon Core – I spent less than $350 for a used Mac Mini i7 with 16GB RAM and a 512 GB SSD.

As Johnny-Ooooops notes above he’s running on a 918+ without issue.

Thanks! I appreciate that a “nucleus” is not required and less expensive options for a core do exist. But the core system running on a supported NAS system “should” also work I believe. Slow response and other potential “glitches” aside, I would not think that attempting to play a single local file would bring the core to its knees. And, as already noted, other folks are running the 918+ as a core without issues, so I must have something messed up!

Hi Forrest,
has the issue been sorted out for you?

I’m facing the same problem since some time. Only local files won’t play and force the core on my Synology DS918 to crash. Only a restart of the core brings the core back.
Since I mostly stream files from Qobuz I don’t exactly know when the problem did occurr.

actual Roon versions 2.0 build 1169 on both Mac and Core


Nope! Problem never resolved. I ended up putting a Nucleus in the system. I did, however, install Roon on a different Synology NAS (DS718+) and while it works better, it is still not as good as when it runs on the Nucleus. Definitely “something” going on…

I got the solution over night from Christopher Crieke:

Have you also supplied ffmpeg in the /RoonOnNAS/bin directory?

Copying the ffmpeg file in the directory and restart the core fixed the issue.