Roon Core no longer finding any of my 23000 locally stored tracks, only my Tidal library

Roon Core Machine

Roon Core:
V2021-10-0 running on QNAP TS-453D
QNAP Firmware version is and is “up to date”
Intel Celeron J41254, 2.7GHz, 64bit
256GB SSD (running the Roon Core)
2 x WD Red 4TB Hard Disks (in RAID 1) storing the media

Networking Gear & Setup Details

The QNAP is wired network to BT Router using good quality cable
Also wired are some “control” points such as my desktop PC, a Dell, i5 with Win 10 Pro,
and good strong WiFi cover all over the home and more Roon Remotes on 2 x Android devices
Also wired are some endpoints including my Denon AVR4500, Cambridge Audio CXNv2, and Chromecast Ultra
Other end points are connected via WiFi

Connected Audio Devices

A variety of Roon Tested and Roon Ready end points including:
The desktop PC with Nuforce USB DAC over Wasapi and ASIO drivers
Cambridge Audio CXNv2 (connected wired to BT router)
Bowers and Wilkins Formation Flex (connected wirelessly to BT router)
Chromecast Audio (connected wirelessly to BT router)
Chromecast Ultra (connected wired to BT router)
Denon AVR 4500 (connected wired to BT router)

Number of Tracks in Library


Description of Issue

Roon seems broken today, and done many things to try and fix, still broken , hoping you good forum members can help

I run Roon off a QNAP TS453D NAS, it has Roon version V2021-10-03. The Roon app runs off an SSD and the media sits on a RAID1 of 2 x 4TB WD Red Hard disks. It has been running fine, since i put it in, indexing about 23000 tracks .
From my Roon dashboards, I then use the Focus feature to create subsets such as “lossless” or “hi-res” or “DSD” so I can if I want browse the entire collection of just a subset, I am also linked to my Tidal account.

I use Roon Remote on my Android phone and tablet, and have Roon running on a desk top computer again accessing the Roon Server on the QNAP to browse and control my music collection, and stream to a number of both Roon Ready and Roon Tested end points around my home.

It’s been working well until today, (mind you not used it for a couple of weeks).

Today, whichever control point I open (windows PC front end, or Android front end) my entire locally stored collection has disappeared and I am only seeing the music on Tidal that I have added to my library.

Trust me, its all still there,

I also have PLEX running on the same QNAP, indexing the same library, and its all there and I indeed am listening to some of that music right now as I write this (thanks to Plex).

Here are the things I have done to try and fix it, NOTHING has worked.

  • I have checked that the correct root directory hasn’t inadvertently been removed from my library (it hasn’t)

  • I did a force ReScan of the parent top level directory where all my music lives (Settings. Storage, Force ReScan)

  • I have opened my QNAP dashboard and stopped and restarted Roon.

  • I have restarted the QNAP I have checked I am signed in to the correct core (I am, and I don’t have any other cores running)

  • I located the most recent back up, and restored it 🙁 and it is STILL only showed content from Tidal (but that back up was auto created yesterday and I don’t know when this issue started

  • I went back to an earlier back up (feb 26th) and again only my Tidal content is showing up.

  • I went back to an even earlier backup (feb 19th) and apart from the number of Tidal Albums changing, again none of my own library is there,

  • I removed and re added the storage selection, expecting that would force a full scan.

Really hoping I can find a fix…

My annual renewal is coming up and frankly, I may not bother, (was thinking of a lifetime subscription)

Look into the thread I link bellow, maybe this can help you:

Nope, that’s not the issue, add that to the list of things I have tried that didn’t work. All the folder permissions already set to read/write

A bit more info
When I use the Settings/Storage feature to add the file location, I can browse from the root directory down through all the folders/subfolders to inidivdual FLAC files if I want.
So roon can see those places, but it is NOT indexing them in my library :frowning:

Today I have deinstalled and reinstalled Roon on the NAS and restored from back up my library, that didn’t work

I also deinstalled (again) and reinstalled (again) on the NAS, and added from scratch the shared location and foreced a scan, again nothing. none of the 23000 files is detected. This is the same collection as has been indexed and enjoyed through Roon for many months and that Plex is still quite happily streaming off the same platforms.

Sounds like you need @support (or maybe @crieke; the NAS guy) help, so I have tagged them to that end.

Thank you for tagging @support, 2 days has gone by since my post and a day since the escalation… and no one has been in touch, and it is still not working… I have also sent Roon Support team a message directly.

Its disappointing not to be able to get support

Really hoping someone reaches out to nez prepared to roll up sleeves and work through things

This went wrong off its own accord, it’s been fine and I simply don’t know what’s happened or how to fix given the many things I have tried

1 Like

Hey Guy,

Sorry for a late reply here, i’m involving my colleague to look into your log to see if there anything we can spot.

meanwhile, can you set up a new core on your pc and add the same location to see if you have the same result? thx

Thank you Yaohan, I will try that and let you know how it goes

I deinstalled Roon (again) from the QNAP, and also reinstalled Roon (set up as roon remote) on my windows PC, and made a fresh install of Roon on my PC setting up as “core”. I pointed the destination folder to a subfolder on my NAS containing all my lossless audio collection and it immediately started scanning away, so far 248 albums found, no issues, .

So this is how I used to run roon, using an older NAS, then in December I upgraded my NAS at considerable cost so that I could run Roon on it, so whilst using the PC works it is not the solution I seek, therefore I look forward to your further recommendations

All the best and thanks

(tis up to 429 albums now!)


So another day has gone by with no support other than “run your roon core on something else”, whilst a work around this is not a satisfactory solution. I researched carefully what level of NAS was needed to run Roon on NAS, I invested several hundred £ on QNAP hardware, SSD and HDs, and moved everything over to the NAS. It ran fine for several months. Why has it broken? More importantly (considering that things can indeed go wrong), how to I get support?.
I have put the details here, I have messaged Roon support directly, and apart from one response from @Yaohan , i have had no support from Roon at all.
Helpful suggestions have been appreciated both here and in a Roon Users groups on Facebook but every suggestion has been followed and failed to solve the problem, and the lack of support from roon themselves as opposed to other users is not acceptable and is worrying…(considering I was about to buy a lifetime subscription in April as opposed to annual)

Hi @Guy_Gampell1 ,

Just to confirm here, you have tried to change the guest access rights from read/write to something else, such as read-only and the issue still occurred? Even if you ahve them already set to read/write, please try to change them to read-only and see if that helps.

Thanks I believe i did but I will try that again
Change back
Reboot again

Give me 10 mins

Hi, I have fixed it with your help, it wasn’t quite as straightforward as changing the access, but I followed a hunch and… well… please read on

First I changed the access to the share containing my library from Read/Write to Read only, Rebooted the NAS, Changed it back to Read/Write, Rebooted the NAS, tried Roon and still nothing detected,


Then I decided to try one more thing.

There are several shares set up on the NAS, one which has “All Our Media” on it, including music, photos, videos, and a couple of other shares for “other stuff 1” “Other stuff 2” etc. Deliberately I had assigned the Roon Database to one of those “other shares” that is used for nothing else at all. So… I went back to the NAS and changed that share from read/write to read only. Not the share that holds the library, but the share that holds the database. I didn’t reboot, just stopped and started again Roon server.

And lo and behold


Thank you all, especially @noris

Super excited to get Roon back as I wanted it

1 Like

Hi @Guy_Gampell1 ,

Glad to hear that changing the Roon Database share permissions resolved the issue on your end, this is wonderful news! I hope you have a smooth Roon experience moving forward and do let us know if we can help with anything else in the future!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.