Roon core no longer starts up

Roon Core Machine

Windows 10 pro version 10.0.19043 Build 19043
Intel Celeron CPU J1900 @ 1.99GHz, 4 core

Networking Gear & Setup Details


Connected Audio Devices


Number of Tracks in Library


Description of Issue

I have been running Roon core without any issues on the machine above. About 3 weeks ago, Roon core no longer starts up properly. The Roon icon appears momentarily in the system tray but when hovered over with mouse it disappears.

I have followed your instructions @ Roon on Windows won’t start or crashes right at launch ( - except that I cannot find a way of reinstalling the .NET framework. I downloaded 4.8 but when installing it says it is already installed.

I have uploaded Windows event logs and Roon logs to your upload area.

Looking at the event logs, there appears to be a problem with Roon and the .NET framework.

Please advise,

Thanks, Mark

Are you running Roon Server, rather than Roon?

If so, try reinstalling Roon Server again.

Thanks, I am running Roon server and have tried reinstalling several times.

I think there is an issue with Roon and the .NET farmework

You can check if .NET 3.5 is installed. Read the posting below:

You can also use the forum search. So far it seems everyone was able to resolve this issue.

Hi @Mark_Newman,

I know it’s been some time since you first reported this issue, but I wanted to check in:

Have these symptoms resolved with the steps @BlackJack suggested?

We’re here to support if so. Otherwise, this thread will autoclose in about 24 hours.

Hi - thank you everyone for your suggestions.

In the end I was able to download a Microsoft .NET repair tool which I ran, and then reinstalled Roon Core which resolved the issue.


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.