Roon core not found after backup to USB flash drive

Core Machine (Operating system/System info/Roon build number)
Roon version 1.7 (build 511)

Intel NUC NUC7I5BNH w/
Intern SATA M.2 SSD 2242 Box Transcend MTS400S M.2 128 GB
Corsair 8GB (1x8GB) / 2133MHz / DDR4 / CL15 / CMS08GX4M1A2133C15
WD Red 1TB 2.5" SATA III

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

NUC connected via Ethernet to router Technicolor tg799tsvn v2.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Chord Mojo connected to NUC via USB.

Description Of Issue

When doing backup to my USB flash drive (Kingston DataTraveler SE9 G2 64GB USB 3.0, formatted as FAT32), it works fine when I do the backup manually and remove the memory stick after power down of the NUC.

However if I keep the memory stick inserted next time I power up the NUC Roon Core is not found. Doesn’t matter if I check on my iPad Pro, iPhone 8, Macbook Pro or old iMac… This has never worked on 1.6 and doesn’t work on 1.7 either. Never tried any other USB flash drives.

It is a bit of an annoyance as I would like to forget about those backups and let them run automatically.

Hmm, are you running ROCK?

No matter, I suppose.

Try going to the BIOS for your NUC and change the boot order so that the drive that Roon Core is on (presumably your OS boot drive) is ahead of the thumb drive.

Yes, I am running ROCK on the NUC.

Ok, will have to bring it to some friend who runs a PC then, as only macs are available here. Sounds like a plausible explanation (and I can’t remember the order now. Presumably the one suggested in the instructions, which I remember I tried following to a T).

Hi @Martin_Friberg,

When this occurs are you able to access the Web UI? If so, can you share a screenshot of this the next time it happens?

Yes, but that was for installing ROCK from a thumb drive onto your primary drive

You are doing something else when you are backing up to a thumb drive.,.
Therefore, you probably need to change the boot order.

Hi Dylan,

Just tried and after backup and restarting the NUC, I can’t reach the web UI any longer. After I power down, remove the USB flash drive, and power back up, the web UI returns.


Yes, because ROCK never booted up.

At boot up time, the machine will try each device, in turn in the order that BIOS specifies to find an OS.

Normally, there would be no thumb drive inserted so the machine will look at the next drive for a boot signature (in this case the M.2). By leaving your thumb drive in a boot time, the machine looks there for an OS. It finds something, but it isn’t an OS so it fails to boot.

When you have he ROCK thumb drive in when you installed ROCK, the machine boots from there. You only want to do that once.

You can temporarily change the boot order, as a test. On a Intel NUC, press F10 at startup. You’ll get a screen that will let you specify the boot order for the present startup only.

Call it a proof of concept before you take it somewhere to muck with the BIOS.


Depends on what Dylan will reply, I am all for checking out what you suggest. Like I said before, it sounds very plausible the boot order is incorrect. But before doing that, I will check the other USB connection on the NUC. I usually go for the same input, as it is easier to reach. Maybe the 2nd input is after the ROCK disc.

Probably not, but have fun.:wink:

1 Like

Hi @Martin_Friberg,

Thanks for confirming that the Web UI cannot be reached. As Slim suggested, it definitely sounds like there may be a boot order problem, so performing the test he suggested (temporarily changing boot order) definitely seems like a good first step here. Let us know how that goes!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.