Roon Core Not Found...redux

Roon Core Machine

Running Roon Core on NUC10i7FNH. It is set to update automatically when Roon drops an update. (Obviously since I can’t access the NUC on the network I can’t confirm the current version.)

Networking Gear & Setup Details

Modem: Arris Surfboard SB 8200.

Switch: 8-port TP-Link.

Interfaces access Roon by WiFi, which is routed by a Google wifi router system.

This exact and unmodified configuration has run fault free since February 2021.

I tried bypassing the switch and connecting direct by ethernet to the Arris. No change.

Connected Audio Devices

There are no audio devices connected directly to the NUC. Everything connects by wifi.

Number of Tracks in Library

No idea. 250,000 would be my guess. This has not changed since it was first connected.

Description of Issue

Roon core not findable. Does not show up on the Network.

NUC is ethernet hardwired to 8-port switch, which is hardwired direct to modem. (There are three other devices running from the switch and none have any issues.)

While I will list the nine (9) different interfaces, the problem is OS and device agnostic; across-the-board. None of the below listed devices sees the Roon Core on the network.

  1. iMac running Monterey (main machine)
  2. iMac running Big Sur
  3. MBP running Big Sur
  4. iPad Pro running iPad OS 14
  5. iPad Pro running iPad OS 15
  6. iPhone running iOs 15.2
  7. BlueSound Node 2i, with a Raspberry pi connected.
    8/9. Apple TV (2x)

We live in Lake Tahoe, and have had substantial and frequent power outages and–sometimes related and sometimes unrelated–internet outages over the past 10 days due to weather.

I have power cycled the NUC several times because when the power comes back on it does not start the NUC automatically. 2 or 3 days ago it stopped being seen on the network no matter what I do.

Yes. Power is on. Yes. The Network is live. As far as I can tell everything is on the same network. The logs show that I’m running v 1.8, but when I click “About Roon” nothing happens. The preferences function in Roon v 1.8 also does not work.

I uninstalled and reinstalled, and the “About Roon” function/info and Preferences panel still do not work.

Info in Finder says it was last updated on 12/23/21, which seems to correspond pretty closely with when things went kablooey. (I believe this to be true. But I do not recall specifically when I upgraded to the most recent version due to the confusion created by all the power and internet outages but that sounds about right to me.) Info also shows a (c) of 2016. Power was out ALL day on the 24th and the 26th. Did not try to access on Xmas day or at any other time until yesterday, Dec 30.

If I had guess, I’d say v 1.8 is the problem, but I don’t know that. If someone asks I can run the last log that I have.



This sounds very similar to the problem I’ve reported here.

Rebooting the NUC solves the problem temporarily but I can see nothing in the Roon logs or Event Viewer to give a clue as to the cause.

Sorry I can’t be more helpful. Maybe @support can suggest something.

Aidan Gaule

Thank you. So I guess I’m not crazy.

I suspect it’s an issue with 1.8, but have no way of checking that.

Have you found any solution since you first reported it? Did the Roon tech folks help?

Apologies if you mentioned this already - I only quickly read the post - but have you connected a monitor to see what, if anything, is output there? It may give a clue.


1 Like

No, but that’s next steps. It’s something of a hassle to do as the NUC and its HDD are “well stored,” and access to the whole shebang is cumbersome. I thought I’d try here first to see if there’s some widely known “aha” fix that might avoid major exploratory surgery.

1 Like

I’m wondering if it might be the WD HDD I have attached to the NUC.

I disconnected it and ran Disc Utility>First Aid on it in my desktop. It checked out ok, but it does not show up in Finder at all, and does not show up in another disc space manager I use (OmniDisk Sweeper). When I re-connect it to the NUC the NUC still doesn’t appear on the network.

Any other suggestions on what I could do to chck the helth of this drive without having to reformat and repartiton it?

Do you have another cable to try with it?
I had a bad cable on one of my USB HDD and my first thought was that it was a bad HDD.
Fortunately I have a number so swapped cable for one of the others and it was then found.
Just a thought…


What OS are you running on the NUC?

I don’t remember. But it appears that I have to deconstruct the whole thing anyhow, set it up with a monitor, keyboard, etc. and see what I’m dealing with.

Off topic musing: The irony of all this being that I got the NUC because, after tons of reading, it seemed to be the easiest to maintain—in a mostly hands off way—once it was set up. A truism that was true until it wasn’t. I’m not a fan of tinkering with tech. I got Roon and am a “lifetimer” because I’m a music lover. I’m beginning to wonder if it’s more headache than it’s worth. This must be what it’s like to own a Jag. Fun when it works, but when it goes bad it goes bad big.

Back to our regularly scheduled programming.

I also set up another Roon Core pro tem, back on my desktop. What a PITA that is—mostly because the machine needs its “sleep” time—and now I remember the other reason I set up the NUC. It doesn’t sleep so my devices don’t lose the connection.

1 Like

Hey @dcw96161,

Thanks so much for letting us know about the issue you ran into — so sorry we weren’t more responsive than this. The silver lining is seeing the community be a community and chiming in in the meantime. Thank you all for contributing :pray:

I’m glad to hear that you and yours are well, despite the incredible amounts of snow in Tahoe that, while beautiful seem to have been accompanied by power and internet outages.

As I was reading the thread, I was hoping you wouldn’t have to touch the very well tucked-away NUC. Since you have, could you please share a photo of what’s displayed on the connected TV/external monitor?

Hey Rebeka

  1. It’s not close to resolved.

  2. I have pulled the whole thing and set up a temp work station. When i turn on the NUC, the screen shows thw following:

Manufacturer: Roon Labs
Model: Roon Optimized Core Kit
OS: RoonOS 1.0 (build 227) stable
Serial xxxxx
Host name: ROCK

Searching for network address…

If this persists, please check your network connection.

No surprises here, except I don’t remember having to be online just to boot up. The room where I have this all set up at the moment is about 60 feet from the router. Getting everything back within Ethernet range of the router is yet another PITA tear down/set up.

I just want to boot into the OS and see what’s going on…if I can.

How can I look at the OS settings without being online? It MAY be a network error.

As to your specific question, see attached.

When i power cycled it, now I get the BIOS screen. Also attached.

I went into setup, but I’m at sea now.

You cannot. The only way to interact with ROCK is via the web interface.

edit: NuC ethernet interfaces are not immune to failure. You’ll need a second ethernet interface (usb) or USB stick boot a live OS and troubleshoot the network that way. If your ethernet port on the NuC is dead… well… no ROCK.

1 Like

Thanks. That sounds like a relatively cheap fix. But to clarify…that’s the only way to figure out if the ethernet interface on the NUC is fried?

Of course, if I do schlep all this junk up to the router and plug it back in and I get the same “searching for network” message that likely answers that question I would assume. (Is that assumption correct?)

And if the EI has gone bad, do I need to replace the NUC or just go forward with the usb ei?

Maybe the NUC got Covid and the ei failure is just the first domino to fall.

I would live boot another OS. What that means is booting and running something like Ubuntu live from USB stick (don’t install it, it shouldn’t touch your internal drive). If Ubuntu Live boots and finds the network then your hardware is good and send the results back to Roon Labs. If Ubuntu can’t initialize and attach to the network then you’ve got a second data point for a hardware issue.

Up to you but… I don’t know what USB Ethernet dongles ROCK supports. You’ll want to verify before deciding on this option. It is the cheaper option than a new NuC though.

I wouldn’t expect COVID to take out the ethernet… Flurona, now… that would certainly take out the ethernet :stuck_out_tongue: Mask-up while working near the machine for safety!

1 Like

Thanks. I was going to ski this weekend, but maybe I’ll just do this instead…

Hey @dcw96161,

I’m glad Monday has come and we can get back to finding a resolution :nerd_face: . Thanks for engaging on our community on the weekend even if Roon staff wasn’t here :pray:

I do hope you got to go skiing too, not just troubleshoot Roon… you’re in Tahoe, after all :star_struck:

Before going that route, it can’t hurt trying to reset the network settings on your ROCK:

  1. Connect or keep the ROCK connected to a monitor or TV via HDMI
  2. Connect a USB keyboard to the ROCK
  3. Press ENTER
  4. Type resetnetwork
  5. Press ENTER

Any change?

Thank you Rebeka. I will try this and report back. Right now I’m off to go skiing as you suggest.

Yesterday I wrestled with getting Ubuntu installed to flash to see if I can get a network connection on Ubuntu. But I had to use my iMac, with Apple Monterey installed to download and install Ubuntu. But Monterey—far and away the most invasive, controlling and uncooperative OS Apple has ever released—won’t even let me log into it on my iMac to see if it installed to the thumb drive properly.

(There’s a ridiculous irony in downloading an OS to see if another OS is operating properly, but the diagnostic can’t happen because the suspect OS won’t allow the diagnostic OS to even load on the hardware. Richard, III’s line, “my kingdom for a horse” comes to mind.”)

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.