Roon Core not found (SonicTransporter)

I recently returned home from a trip and now my laptop roon app can not find my roon core. (on sonictransport) When I hit help and enter the ip address, it does nothing but continue searching for roon core. I have restarted all my devices (sonictransport, laptop, modem, router, ultrarendu) to no avail. Devices are all showing on network map and the sonictransport is operational. I need help troubleshooting.

Have you already rebooted everything?

Hi @David_Warner ---- Thank you for the report and sharing your feedback with us. The insight is very appreciated and sorry to hear of the troubles?

Moving forward, to help aide in our evaluation of this behavior may I very kindly ask you to please provide the following information:

  1. Please provide the make and model of the laptop not being able to connect to the ST.

  2. If you have other devices acting as Roon remotes are they displaying the same behavior as the mentioned laptop?

  3. Are you able to communicate with the ST on your network from the laptop without issue outside of Roon?


HP Spectre x360 convertible, 64 bit windows. I have no other roon remotes. The only way I have communicated with the ST is through SGC website to confirm that it is still operational.

Thanks for the follow up @David_Warner and providing the requested information!

Continuing forward, please confirm that there are no active firewalls or antivirus applications running on the Windows laptop. If there are please temporarily disable these functions and confirm if this actions yields a change in behavior.


1 Like

Turning off antivirus and firewall has no effect on detection of core.

Thanks for giving that a shot for me @David_Warner, appreciated!

Kindly provide the following:

  1. The IP addresses being assigned to both the ST and the Windows laptop having the issue.

  2. Confirm that you are able to successfully ping the IP address assigned to the ST from the Windows laptop.


IP address for ST is
IP address for laptop is
Was able to successfully ping ip address of ST from laptop.

Great! Thanks for confirming that information for me @David_Warner!

Being that the ping test was successful and the IP addresses are in the same range, something else must be causing the issues here. I have seen this kind of behavior in the past after an automated Windows update has occurred which usually resulted in some security setting being changed due to the updated, which was why I inquired about the firewalls/antivirus applications on the device.

In light of the above may I kindly ask you to please describe your network configuration/topology being sure to provide insight into any networking hardware you are currently implementing. I want to have a clear understanding as to how your devices are communicating and all the tools involved with making those connection possible.

Furthermore, can you please reinstall Roon on the laptop and verify there are any changes in behavior with the device?


Modem and router (Asus rt-ac68u) upstairs – router wired connection with ooma telo, sonic transporter. Router to powerline ethernet adapter. Powerline ethernet adapter downstairs to ultrarendu and integrated amp. Numerous peripherals connected wireless. Reinstalled Roon on laptop - no change.

Thanks for the additional insight @David_Warner! Appreciated!

This is still feeling like a firewall/security setting issues to me on the laptop especially since there is nothing “exotic” about your network configuration. Before we consider enabling diagnostics/looking at logs would you kindly provide the following:

  1. If the laptop that is having the issue can make sure of hardwired connections could you please mount the device directly to your router via ethernet and verify if it can connect to the core successfully.

  2. In windows you can setup two types of networks, ‘Private’ and ‘Public’. When you disabled your antivirus software and the firewalls, did you disable the firewalls for both the ‘Private’ and ‘Public’ networks?


There is no ethernet port on my laptop. Disabled firewalls public and private again and no change.

Hi @David_Warner ---- Thank you for the follow up and giving the proposed troubleshooting tests a go for me.

There is one last series of troubleshooting exercises that I would like to have you perform to see if we can pinpoint the variable, or possible variables, that could be causing this behavior to occur with the laptop. Kindly see below.

  1. If you another device (i.e a phone, laptop, tablet) that can be used as a Roon remote please load the application on to the device of you choosing and verify if it can connect to the ST as expected.

  2. I would like to remove some variables from the “chain of communication” and see how the laptop responds with the very basic network configuration in place. With this in mind please perform the following:

    • Please temporarily remove the ethernet connection running between the router and powerline adaptor.
    • Please also temporarily remove the OOMA TELO connection from the router.
    • Now with the powerline adaptors and the OOMA TELO temporarily disabled and only the ST attached to the Asus modem/router, is the laptop able to connect?


Installed on Android phone - still get network error. Removed ethernet from router to powerline adapter, removed OOMA connection. Still no connection with Roon core.

After removing the powerline adapter, I am having trouble getting the middle led (powerline) to light. Troubleshooting the powerline adapter now.

Powerline adapter working, still not detecting Roon core.

Bump - Still need assistance.

Hi @David_Warner ----- Thank you for giving the proposed troubleshooting exercise a shot and sharing the results with me. The additional insight is very appreciated and my apologies for the delay.

Before we look into gather diagnostics/logs I would like to have you try one more test to see if we can isolate this behavior a bit. Kindly see below.

  • Please temporarily power off the ST.
  • Next, please launch Roon on the laptop that is having the issue and temporarily designate this device as your Roon core.
  • Finally, please confirm if the Android phone that you used for the previous test is able to locate and connect to the core temporarily being hosted on the laptop.


With the ST disabled and the laptop as core device, the Android phone is able to connect with the core on the laptop.

Hi @David_Warner ---- Thank you for the follow up! I appreciate you sharing the results of that test run with me.

Just to make sure we are on the same page here. With all of your networking hardware in place (router, OOMA TELO, and powerline adaptors) the remote was able to connect to Win10 laptop acting as a test core without issue, correct? The only change that had been made was the Sonic Transporter was taken offline, yes?

Additionally, I did some searching around the community site because I had remembered that awhile ago I had two users reporting similar behaviors to us and came across this thread: