Roon Core not launching after 1.7 update

Core Machine (Operating system/System info/Roon build number)

NUC i5 8gb ram running win 7, latest Roon build 1.7 as of Nov 22

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

TP link Archer D9 connected via ethernet

*Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Connected USB to Parasound Halo integrated amp

Description Of Issue

Was excited to install the new 1.7 update. Opened up the nuc and the Roon window showed the update was ready. I clicked the “update all” button and nothing happened. I waited about 10 minutes. There was no indication of any download happening or any update in progress.
Since nothing was occurring I decided to shut down the application. I tried to restart it and it refused to boot up. I attempted a number of times. About now I was getting worried.

I downloaded the new update from the Roon site and installed it again. Same issue.

I then uninstalled roon “application only” and tried again, same issue. I’m hesitant to uninstall everything including all my settings and databases fearing I might loose all my library.

What are my next steps and what do you think the issue is? It feels like the update was corrupted somehow. Awaiting your reply. Thanks

EDIT: To clarify when I launch the application the Roon window boots up and shows the artist quotes then shows the animated “jellyfish” icon for a few seconds, its starts to stutter and freeze, then the window closes automatically. I’ve rebooted the machine a number of times and attempted a few uninstalls and reinstalls with no luck. I have log files zipped up below:


Hi @Graham_Irvine1 — Thanks for sending the logs over. I’ve passed them along to the team for review and we will follow up as soon as we have their feedback.

Thanks Dylan. After some digging on the forums I found the issue might be a graphics driver update. Sorted that out with my Intel HD graphics card and all seems to be working now. I’ll let you know if it stays stable. Thanks

1 Like

Great, thanks @Graham_Irvine1. In the event that you see this behavior return, this may also be related to the version of .NET that’s being used on your device, so try installing the latest framework version here and that should help.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.