Roon Core not running properly in Win2012r2

I am currently running Roon Core on a Win10 VM. My music is located on a Win2012R2 server the same that hosts the VM. I was never able to run Roon Core on the Win2012r2 which is where I am running domain controller, hyper-v etc. My goal is to move the Roon Core to the Win2012R2. I will upload the logs and screen shots as soon as I figure out how to. My controller is a Win10 Asus Laptop as well as LG tablet and Samsung Galaxy 6. My end points are a Win2012r2 running RoonBridge which is connected to a Dac,audioresearch amp, sanus fabre speakers, a RPI2 running RoonBridge and connected to a Onkyo Receiver through HDMI and a RPI3 running RoonBridge connected to a HK pre-amp, carver amp, NHT bookshelves and a subwoofer. When I shut down the Win10VM and try to run Roon Core on Win2012R2, my controllers can not connect. Any help would be greatly appreciated.
Please find the following links:-

Hi Ahmed,

Have you installed the Media Pack for Server 2012R2 ? The default Server 2012R2 doesn’t contain media codecs needed for Roon Core.

Andy, I had done that. I had also followed the user guide to back up the library and install it into the new location.


From the info you’ve provided it looks like your remote can see the core, but the connection isn’t being fully established. This usually suggests that traffic between the two is being blocked and in this case it could be the outbound packets from the core.

Do you have a firewall enabled? If so can you try deactivating it for testing? Are you running any security software which may limit an application’s outbound connectivity?

This gets more complicated with Hyper-V and its virtual network interfaces, so it’s worth disabling anything that may be getting in the way.

I will look into creating an exception for Roon as it might be running some sort of server based firewall for the Win server. I will keep this thread posted.

Roon and RAATServer are the processes to whitelist.

I have created both inbound and outbound policies for the Roon executables, but my luck has not been changed. The controllers will not connect to the server. I had made sure that there is not any other core that has been running at the same time. Looking at the logs, the RoonServer connects to the storage and fetches all the information, it needs for itself. The links for the latest logs are below:-


Flagging for @support

1 Like

Hi @ahmed_iqbal ---- Thank you for the report and the feedback here, my apologies for the troubles. I am going to take a ticket out to have one of our developers review your logs and see if we can pinpoint what may be going on here. I will follow up with their feedback/findings of if any additional information is needed.


Hi @ahmed_iqbal ----- I wanted to touch base with you here and see how things are going. Has any new progress been made?

My developers have had a chance to take a look at the provided logs and review all of the information you have supplied to us. Our developers believe there may be an issue occurring here at the OS level as the Roon core can be detected on the VM but cannot be found on the 2012R2 server.

They have suggested making sure that jumbo frames are not engaged and to remove/disable any software that may be taking control of your network connection.


Unfortunately, nothing has changed on my end. I have Plex running on the same server and its clients have no issues connecting to it. So I tried to create the inbound/firewall rules, copying what they were doing, but no luck.


Hi @ahmed_iqbal ----- Thank you for the follow up and my apologies for the slow response here.

I can tell you that the symptoms you are noticing are synonymous with what we’ve seen in the past when firewalls are active in a user’s setup. During your testing, were your firewalls completely disabled? What else have you tried since? I can gladly look over what you have tried thus far.