Roon core not starting after backup recovery [Solved: older backup]


Roon Core Machine
Windows 10
Core i5 Lenovo thinkpad T420
8GB ram
Ethernet connection

I reported this issue a few days ago and it got sorted out on its own, but I had to reinstall my computer and now the issue is back. This time it doesn’t look like it’s resolving itself.
Here is a repeat of the issue:

I am attempting to migrate my Roon core from an older i5 desktop to a slightly newer i5 laptop.

I installed Roon server on the target computer and restored Roon DB from a recent backup (1 day old). The restore completes with a message to relaunch Roon, but then after clicking the relaunch button, the Roon server status goes into a loop of: started—>error—>not responding.

Restarting the laptop several times did not help.

Uninstalling Roon completely, installing again and restoring again results in same situation

Please advise

I see from the log that Roon is not able to copy the old db to a .restore_old folder and not able to copy the recovered db from the .restore_on_launch folder, claiming that access is denied.
I checked permissions and everything looks ok.
Can I just perform the copy manually?

Try an earlier backup date, sometimes things get corrupted, and an older copy might be workable.

1 Like

Hey @Marc_Stern,

I’m so sorry the problem returned :sweat:

@wizardofoz has read my mind and was much faster :zap: than I was in making this suggestion. Thanks, @wizardofoz - we’re grateful.

Please, let us know how does an older backup work :nerd_face:

Thanks rebeka
Since this is a new core I only have this 1 backup, but like in the previous time eventually it got sorted out in its own, just took much longer.
In the first time it was just a couple of hours and now it was an overnight.

Bottom line, all is good now and I don’t have any plans to migrate again soon, but it is concerning that this happens at all.
I guess if it a singular event it can be dismissed, but you may want to figure out what was limiting the restore from working flawlessly.

1 Like

Hey @Marc_Stern,

Thanks so much for giving that a try :pray: . I’m really glad it worked.

I appreciate your follow up. So far, it seems that corrupted databases are associated with malfunctioning hard drives. Hard drives don’t last forever and they all eventually fail. This is especially pertinent when it comes to Roon, which relies on your harddrive to keep track of all your album art, edits, metadata, playlists, and so on.

There can be millions of objects written in your Roon database, and sometimes there are things outside of our control that can interrupt your harddrive’s ability to read and write data, leading to corruption. It could be failing, maybe the power went out, or something else.

We acknowledge how important this is and I wanted to share that our R&D is considering options to address this, like integrity checks for corruption and stop you from using Roon at all if corruption is detected. Doing this would prevent cases of latent corruption like you’re experiencing, and ensure that your backups are never corrupt.

We’re working on it :nerd:

1 Like