Roon core not starting on QNAP today [Resolved]

tried to restart the core on my qnap - many times no joy - started seeing this today 22nd
no logs are being written today either - i have logs from yesterday - any use ?
i have also checked the disk with the core on it

has been working fine recently
snap is TS-251 running latest firmware 4.3.3

any ideas how to solve?

Reboot the QNAP for starters?

Let’s flag @crieke here. He may have some ideas for you once he’s slept off the Munich blues. :wink:

1 Like

What version of the RoonServer qpkg is installed? Did this behaviour start when you upgraded your QNAP to QTS 4.3.3?

well the qpkg has always reported as 1.0 on the nas even though it has gone through several updates to 1.3 on the core - as far as i have found that is the only avalable version?

as the core is automatically updated.i was running the uptodate version of the core looking at yesterdays RAATServer logs it reports as RAATServer v1.3 (build 223) stable on linuxx64

regarding the firmware on the NAS (qnap TS-251) it was TS-251 recently but i reverted about an hour ago to see if this woud help - still no joy.

I have a bunch of uptodate backups for my roon setup, but if i cant get to the core how would i run a restore? maybe this would help ?

reading your question more carefully - yes i ‘think’ the problem started in last 1 or2 days which is approx when i did last firmware upgrade to the NAS hence my testing of an earlier version on the firmware

QTS 4.3.x switched completely to 64bit. I made a new update for RoonServer already in November to address incompatibilities that were resulted by that. Could you try to uninstall RoonServer on your QNAP and reinstall the current qpkg from my blog? Your database will not be touched by doing this…

There is a misunderstanding here: The core does auto-update. But it only updates all parts of RoonServer. The QNAP needs also some scripts to set the right environment for RoonServer. These scripts needed a modification due to QTS 4.3.x. (see post above) and unfortunately do not auto update by RoonServer.

I hope I can make this easier soon and hopefully get RoonServer in the QNAP App Store.

1 Like

will do hopefully today - will keep you posted

Oh - my bad - i had core and server interchangable in my head - so i misunderstood your blog when it said it would automatically update the server, thinking that meant all of the backend - many thanks for the clarification. I will download the new qpkg and see how i get on.
many thanks for the help so far - fingers crossed - pete

Hey Christopher - IT WORKED - thought it was going to be a many step thing setting up things after the upgrade - clearly i dont have a clue how it all works. I am now running 2017-02-02 on the NAS - first glance everything seems to be working perfectly again. I’ll go back to lastest firmware on the NAS later but assume that will not give and issues.
MANY mank thanks for your help - I keep an eye on your blog in future - Cheers Pete

Yes, I switched to a version date some time ago, to prevent people thinking this is the actual installed RoonServer version.

1 Like

i thought of that one John - i fact with the many firmware updates it gets frequent reboots. @crieke fixed the issue for me. the new firmware was incompatible so a simple update to the qpkg package solved the issue - cheers Pete