Roon Core on Mac OS Sierra cannot mount my SMB drives [Resoved in B161]

I upgraded my Mac Pro (Late 2013) to run MacOS Sierra (10.12 Beta).
Once Roon started up it could not mount SMB disks from my Synology 1511+ any longer.

I removed them from the settings and tried adding them again.
From the beginning with the same settings using the following URL, smb://diskstation/Music with correct username, password and workgroup. I also tried other combinations with and without username/password/work group as well as IP address.

The result was all the same, Roon could not connect to the remote server.

Installing Roon Core on a MacMini running OS X Yosemite, worked fine and using the Mac Pro with Sierra as a Remote works fine i, including local playback.

Is this a known problem and if so is there a way around it?

Cheers
Johan

Never a good idea to install a beta OS on a system you actually want to do something useful.

If there’s any incompatibilities between the SMB implementation in Sierra and the way Roon handles things, these will be straightened out after release for sure, but it would be a bad allocation of resources chasing compatibility with an OS that’s in an ever-changing beta cycle.

2 Likes

I thought I posted in the support forum not the unsupport and be pseudo wise forum…

1 Like

To be clear: you should not expect ‘official’ support running software on a beta OS.

As for community support – I very much doubt anyone would try this on their live systems. But anyway – good luck!

2 Likes

Thanks

Obviously, I made sure to have a fallback solutions provided including another Roon Core Server and a backup of the Mac Pro before upgrade, so no loss of service.

1 Like

A question and a comment: 1) have you set Synology File Services to accept SMB 3 via the advanced settings in the WIN File Services control panel? 2) there’s a lot of discussion online about poor SMB behavior in recent OS X versions – I’ve had trouble with incredibly slow access to large Synology folders over SMB in El Capitan 10.11.6.

1 Like

Yes it’s set to SMB 3.

It’s not that’s it’s slow, it just immediately returns with “Unkown error”.

Sounds like an API change in the OS to me.

Nothing official from Roon?

Hi @qdtjni ---- Thank you for the feedback and my apologies for the trouble here. In regard to your question, we can not guarantee stability with pre-release os builds, but we can certainly take a look for you :slight_smile:

I will be contacting you via PM momentarily with instructions on how to retrieve and upload logs to our servers. Thanks!

-Eric

Thanks, Eric!

I appreciate it.

Cheers
Johan

Been toying with the Sierra GM – connecting through SMB is still a problem.

@Eric: you may want to add this to the ticket.

Relevant part of the logs:

09/09 16:04:11 Critical: [storage/cifs] connecting to //linuc/test: System.UnauthorizedAccessException: Access to the path "/Volumes/RoonStorage_05a47ebf17cc72a1b5349aae043837da9831b395" is denied.
  at System.IO.Directory.CreateDirectoriesInternal (System.String path) <0x119b9ace0 + 0x0019f> in <filename unknown>:0 
  at System.IO.Directory.CreateDirectory (System.String path) <0x119b9aa70 + 0x000d0> in <filename unknown>:0 
  at Sooloos.Storage.CIFSUtil._CreateDirectory (System.String s) <0x11d35a820 + 0x00014> in <filename unknown>:0 
  at Sooloos.Storage.CIFSUtil.Mount (System.String networkpath, System.String username, System.String password, System.String domain, System.String& mountdir, System.String& errormsg) <0x11d342ec0 + 0x00455> in <filename unknown>:0 

After a clean install (Roon dir emptied):

Interesting tidbits: when running Roon as root – do not try this on a functional install! – (sudo /Applications/Roon.app/Contents/MacOS/Roon), it mounted just fine:

When restarting as regular user, Roon failed to load (endless wavering jellyfish – do not try this on a functional installellyfish):

In the logs: multiples of

09/09 16:20:42 Warn: [storage/cifs] /sbin/umount -f '/Volumes/RoonStorage_05a47ebf17cc72a1b5349aae043837da9831b395' failed: (1): umount: unmount(/Volumes/RoonStorage_05a47ebf17cc72a1b5349aae043837da9831b395): Operation not permitted

Good luck. :slight_smile:

so I guess it’s NOT safe to update on 20 september… tick tock :fearful:

The simple reason why it doesn’t work as normal user but works as root is a change of permissions on /Volumes.

In older version of the OS the permission are as follows:
drwxrwxrwxt

But in the Beta MacOS Sierra it is:
drwxr-xr-x

It both case the directory is owned by root.

If you in MacOS Sierra changes it to drwxrwxrwxt, it works but after reboot, it’s set back to the non-working permissions.

I installed the release candidate earlier today.
I’ll try setting the permissions back to workable permissions and see if they remain after a reboot.

If they don’t there are multiple way to work around, for instance setting SUID bit for executables, having a root cronjob set the settings ever so often, etc.

The change of permissions didn’t survive a reboot! :frowning:

Just found this:

"Openradar: https://openradar.appspot.com/radar?id=4948585099558912

Apple have closed my bug report, stating:

This issue behaves as intended based on the following: It was requested by security, you can no longer create items in /Volumes unless root.

Great." https://forums.developer.apple.com/thread/49667

Just tried with a dirty hack, adding a chmod to root’s cron.
As expected, it did work.

jmy-mp:/ johan$ sudo crontab -l
Password:

          • /bin/chmod a+rwxt /Volumes

Roon starts fine and can mount the SMB shares.

However, this is obviously not a permanent solution.
So it would seem like Roon has to access SMB shares directly without mounting, if that is possible in MacOS…

we can mount it elsewhere… but the problem is that we wanted to mount it in /Volumes so you can see/unmount it in Finder

trying to figure out how Finder can do this via the cmd-k thing…

Hi,
I’ve installed sierra 10.12 on my macbook pro (13-inch, Early 2011). And now I have a lot of problems:

  • Roon cannot find my synology DS2014 play anymore.
  • When I play my Roon it crashes.

Can you help me?

You will find information about Sierra and NAS in other threads . . . it is being fixed shortly.

Hi, I’ve merged you post into this existing topic, you will see the issue you reported is being worked on and for now there is a workaround (see qdtjni Johan N) post above.

1 Like