Roon Core on Ubuntu stops accepting connections

Hi there,

Roon and Ubuntu newbie here. I installed Roon server 64 bit for Linux on my Ubuntu workstation. Controlling Roon core from 2 remotes (smartphone and tablet) to play on 1 Roon ready device. All worked just fine that evening, including discovery of small local library and large Qobuz favourites selection.

Next evening my remotes (smartphone and tablet) could not connect to the Core. Stop and start of roonserver on Ubuntu did the trick. Worked fine rest of the evening.

Next evening: same thing…

Is there any additional things I can check, why that restart is necessary. It’s annoying, during my test. Wondering whether to pay for Roon, event though the functionality looks great.

Thanks and kind regards,

Hi @Jan_Stes and welcome to the forum. I’m not technical support, just another user, but I’ll try to offer some help while you’re waiting. The issue you have has the smell of a network problem, Roon/RAAT is pretty demanding in that respect. If you were to give a few more details about the devices and the network hardware and links it’ll help when support do arrive.

1 Like

Hi Jan,

I and some other users have been wrestling with random crashes and restarts of the Roon Server process on Ubuntu Desktop, which seems to be related with NetworkManager and the dhcp4 client calling to its server. One thing you can do to ascertain if you are experiencing similar issues is to look for SIGSEGV events in your syslog archives. You can do that by

grep SIGSEGV /var/log/syslog


grep SIGSEGV /var/log/syslog.1

For the compressed syslog archives (syslog.2.gz etc.) use zgrep instead of grep.

If you find SIGSEGV events related to Roon server processes I’d think we could be fairly sure you’re experiencing the same problem I and others (e.g. @Robem) have had.

In this case, the first thing I’d do is to configure the IP of your Roon Core server with a static IP. If the IP is static, there won’t be any more dhcp4 calls to renew the IP lease from its server, and this for me has ultimately been sufficient to solve the problem. If you do this, remember to configure the IP address reservation on your router to avoid future address conflicts with other devices on your network.

1 Like

Thanks to all for the replies!

No SIGSEGV events.

To my surpirse, it appears my tablet is still working the next day. My phone cannot connect any more.
Is there any way I can investigate the status of the roonserver process on Ubuntu?
Really uncomfortable for me that there is no roon control app on Ubuntu.
Is there a web interface to the Roon Server process?

Thanks and kind regards.

That’s good. In any case, I’d set up the core server with a static IP.

sudo systemctl status roonserver

Not specifically for the roonserver process. This you can control using the systemctl interface from the shell.

But, if you wish to run your Ubuntu core server headless, you could use cockpit as a web admin interface… let’s you monitor CPU, memory, discs, processes, package updates, etc.


Hi @Jan_Stes,

Did adding a static IP help with the issues here? If the issue is still occurring, can you provide some more details regarding your network setup, including model/manufacturer of your gear?

Adding static ip did help. But that is not really an acceptable solution, is it? Roon should work with DHCP.

1 Like

what are your DNS and DHCP settings?

Not A clue. schould be no need to know.