Roon core on win 10 loses connection to services and audio

Did this just start happening?

Since you use remote, did you try running RoonServer?

It’s not uncommon for the iPad to lose connection or Roon to stop seeing the iPad

Restart the iOS app that normally fixes it

i am using the roon app on ipad as remote
and roonserver on the win10

i moved the roonserver aka core from a previous present linux machine to the nuc.
and since then i am having trouble getting this stable.
i tried rock also but this hung up too

OK, I thought that since RDP worked, it might have something to do with video.
I don’t think RoonServer uses video.

unfortunately not in my case. ipad app finds the core, but when it is stale, then i get the no audio devices found message. even though the library is shown
app restart on ipad then doesnt solve it.
restarting the win10 does. Even opening the rdp session to the win10 where roonserver is running get the zones back in the ipad app

but playback also stops after some time without me doing anything except listening.
when the looking at the app, the zones are gone again.

Sounds a bit like your Core is entering energy saving state after some time of playback. Try disabling energy saving as a test.

the nuc is a Intel NUC Kit NUC8i3BEH2 i3-8109U*
with 16gb +250gb ssd

i have disabled it already ( at least in windows energy settings)
i will have a look in bios wether there is some setting that i missed.
that was what i was suspecting also.

I think i found a trace of the Root Cause in Windows Eventlog:

The roonserver crashes

Anwendung: RoonServer.exe
Frameworkversion: v4.0.30319
Beschreibung: Der Prozess wurde aufgrund einer unbehandelten Ausnahme beendet.
Ausnahmeinformationen: System.UnauthorizedAccessException
bei System.IO.__Error.WinIOError(Int32, System.String)
bei System.Threading.EventWaitHandle…ctor(Boolean, System.Threading.EventResetMode, System.String, Boolean ByRef, System.Security.AccessControl.EventWaitHandleSecurity)
bei System.Threading.EventWaitHandle…ctor(Boolean, System.Threading.EventResetMode, System.String, Boolean ByRef)
bei Sooloos.App.GetAppLock()
bei Sooloos.App.Main(System.String[])

Now trying to change the User-Setting of the Service to LocalSystem-Account.

and this led to an empty DB. So Restore is running… (luckily the nightly backup to the nas did work)

Backup restored. seems to run again. Still as nssm-controlled service, but on localsystem with desktop-interaction allowed.
But there is still one issue in eventlog. :
Registry key AppDirectory is unset for service RoonServer. Assuming startup directory C:\Windows.

Any advice here?

shortly later audio devices lost again did work in roon app on a different win machine where all zones were present and streams could be controlled.
but on ipad the zones are gone.

no eventlog on the nuc core this time.
changed now to an explicitly created local win user for the roonserver service
again the db got initialized and restore needed.
the rdp session is permanently open, no energysavings active.
this is annoying

Does this help?

Hi @Rolf_Keplinger,

Can you please use these instructions to access your RoonServer logs from the Windows 10 and upload a copy to Dropbox / Google Drive? If you don’t have either service just let me know and I can provide an alternate upload link.

hello
i think i found the reason
i had also installed the bridge and this was interfering with the roonserver
deinstalled roonbridge and now it seems to be stable
so layer 8 problem. :roll_eyes:

sry for this, but if this helps someone else, then it at least was not completly in vain.
thanks to everyone that tried to help
regards
Rolf

Hi @Rolf_Keplinger,

That’s strange… I haven’t heard of issues with having Roon Bridge + Roon Server on the same PC before, so it might have been something environmental causing them not to work properly on your end. Do keep us posted on if the issue still appears resolved after a few days of testing further.

Hi @Rolf_Keplinger,

I mentioned your case to the QA team and they haven’t seen any issues either of running Roon Bridge + Roon on the same PC.

Do you by any chance have the full logs set for this still?

sry for late reply.
i still have permanent issues with the nuc with windows hanging

so i moved to a docker on my unraid server.
now it is stable

1 Like

Hi @Rolf_Keplinger,

Glad to hear the Docker container is working as expected for you! Would you by any chance still have the previous Eventlog from the issue? This would be helpful to show to QA, just so they have a better understanding of the previous issue of RoonServer + Bridge.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.