Roon Core Randomly Shuts Down

Roon Core Machine

Intel NUC713BNH w/ 8GB RAM
OS v1.0, build 227
Roon Server Software v2.0, build 1128

Networking Gear & Setup Details

Calix 716GE-I optical network terminal
Zyxel C3000Z modem/router
TP-Link TL-SG105E switch
Core connected to switch via ethernet
no VPN
provider is CenturyLink

Connected Audio Devices

Raspberry Pi 3B w/ Allo DigiOne HAT running RoPieeeXL 2022.08.1 (0522)
connected via ethernet

Number of Tracks in Library

<500 albums

Description of Issue

My core will randomly shut itself down. It doesn’t seem to matter whether or not it is in use. I’ve had this issue in the past & was advised to change my DNS settings to point to Cloudflare or Google. I’ve tried both without success. I’m open to any suggestions & can provide any additional information if you can let me know what I may have missed or what you need. Thanks so much!

If you are not running in a Fanless case I would check the fan to see if it’s clogged up.

Google on the internet for how to clean Nuc fans

I should have included that. It is in a fanless case. I don’t think it’s overheating though. Sometimes it will stay on for days at a time. Other times it will only stay on for a few minutes.

I would boot to an OS that will allow you to run some diagnostics, like a Linux Live Boot USB. And see if something might be going on.

1 Like

Hey @Tyler_Schettler,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

I wanted to follow up on this thread to see if you were still running into crashing issues with your core? If so, please take note of the date and time the next time this happens, and share it here.

I’d also like to see if refreshing your database results in the same issue. Please make a fresh backup before following the steps below:

  • Stop RoonServer from running in ROCK’s WebUI
  • Navigate to your ROCK’s Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Roon database folder
  • On the Roon Remotes, press “Use another Core” and connect to the new database

I’ll be on standby for your reply :+1:

Hi @benjamin. I was able to complete the steps noted above & was able to get the core up & running again. I managed to get the Roon remotes on my MacBook & iPhone pointed to the new core. I was also able to log in to Qobuz & add the various Roon endpoints I have (including renaming them, changing icons, & updating volume settings). However, when I tried to group my bedroom & living room endpoints, the core shut down again. It had been up running for ~3 days 22 hours. If it matters, the core prompted an update prior to going through the process you had noted above.

1 Like

@benjamin, just a quick update. I’ve turned the core back on, but now when I try to access it through the remote app on either my phone or computer it just shows that the core is initializing. It has been running for an hour so far.

Hey @Tyler_Schettler,

Thanks for the update, and I’m sorry to hear you’re still having issues with your core shutting down.

At this point, we’ll need to grab a few time stamps (the date and time) of when this crash occurs. We’ll enable diagnostics to see if we can get a deeper look into things.

With your endpoints, I would also triple-check that you have the latest firmware installed, and test to see if they work independently of each other prior to grouping them.

I will be on standby for your reply :+1:

Thank you @benjamin. I am currently out of the country, but will check everything when I return. As of now I can still access the server via ARC. Thanks again for your help!

1 Like