Roon Core recognizes Bridge on DAC, but doesn’t list DAC in network-connected devices

Roon core is running on Windows 10 Media Server (Baetis Ref), running wired into Hub on wired network. Core is running current version of Roon software. DAC (Lampizator Pacific) is also connected via hub to wired network. Network recognizes DAC. Roon Core recognizes Roon Bridge On DAC and confirms it is running latest version of Bridge software. DAC doesn’t list in network devices in Audio settings in Roon. Two wireless devices (running on same network) are listed as network-connected audio devices, but DAC doesn’t list. DAC is showing up as Network server and Media Device in Windows. I tried typing the IP address listed for the DAC in Roon ‘About’ into the browser, but it wouldn’t connect. I can connect to DAC by double-clicking server icon and it just lists with one folder with audio rendering software in it. What am I missing?

Hello @Simon_Bailey,

Thanks for contacting support, I’d be happy to assist here. I have a few followup questions as to have a better idea of what’s going on here:

  • Can you please post a screenshot of your Roon Settings -> Audio Page?
  • Are you by any chance using a different subnet for your Lampizator DAC?
  • Have you tried using another Ethernet cable or port on your hub?
  • Can you list the model/manufacturer of the hub you are using?
  • Can you post a screenshot when it shows up as a Media Device in Windows?

Please let me know the above information when possible.


Hi Noris,

Thanks for the swift response.

Screen shot of audio settings below - note that I don’t use the core server to serve music, hence all audio outputs are not enabled.

The Lampizator is on same subnet as server.

I’ve tried using alternate ethernet cables and swapping ports on the hub, to no avail.

I’m using a Netgear GS608 Hub

Screenshot of Network showing media device and PACIFIC DAC as server below -

Thanks again. I really appreciate your assistance.


As a test, try turning off any Firewalls you have running on your Core. Sometimes they block the Roon network discovery process. If you turn it off and the DAC appears, then you need to verify that both Roonserver and RAAT are allowed as exceptions in the firewall.

Hi Daniel,

I switched off Firewall - made no difference. Also checked Apps given passthrough and Roonserver and RAAT are there as exceptions…

Roon is clearly seeing the DAC -

I just can’t work it out!

Thanks for getting back to me…


Hello @Simon_Bailey,

We are currently discussing this issue with the technical team at Lampizator, I will be sure to share more information once it is available.


1 Like

Hi John,

Thanks so much… I really appreciate the great service… :slight_smile: