Roon core set up not working on Windows 10 - stuck at first install!

I’ve downloaded the Roon software on to my windows 10 PC and instaled it. It opens fine and I log in and then choose, set up a roon core on this computer. It gets to this stage and I get no further:

I’ve turned my PiHole off and have made sure roon is not blocked by my PC firewall. ANyone got any ideas why this gets stuck?

I have also tried restarting my PC and uninstaling and reinstalling the roon software!

Stuck at the first hurdle dammit!!

I have moved your post to the #support forum, so Roon’s @support team can follow up.

thanks! very helpfull

Can you access Roon core using Roon remote app on your mobile?

No, I cannot

Wild guess but check your graphics drivers, there have been a few reports of the recent Win 10 update screwing up drivers.

If you have a graphics card use the manufacturer driver instead of MS

I have the latest NVIDIA drivers

I wonder if it could be my edgerouter x blocking it?

Hi @Ian_Nicholls,

Sorry for the trouble here! Can you give us some details about your PC? What CPU and GPU are you using?

If you install the 32 bit version of Roon instead of the 64 bit is there any change?

I’ll try the 32 buit version in a minute. The PC is running a Ryzen 3600X and a 2060 NVidia GC.

32 Bit tried - exactly the same - it looks strongly to me like something is blocking it from the internet

we can close this - opened all the firewalls, closed them again and not its working like a dream - thanks everyone for your support

1 Like

Thanks for letting us know you were able to resolve this one @Ian_Nicholls, happy listening!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.