Roon Core (still) restarts when starting playback on Chromecast device

Core Machine (Operating system/System info/Roon build number)

ROCK on NUC i5
Roon 1.8 build 756

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Synology RT2600 router
Core and Nvidia Shield (Chromecast) networked with ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

NVidia Shield builtin Chromecast

Description Of Issue
As my previous topic remained unanswered… I create a new one about this problem that occurs one two several times a day.
I’m using my NVidia Shield as endpoint with the built in Chromecast. Very often, when I hit the play button for the first time in the morning, connection to the Core is lost and it takes time before connection is back on my Android remote. As my local library files are scanned once again, it seems that the Roon server crashed or restarted.
After the restart, hitting the play button on remote actually starts playback.

Any update on this problem from the support team ?

Today as every day, this problem occurs once again.
Maybe I’m the only one but it would be nice to have at least a reply from the support team.
It’s the first time one of my topic is ignored like this.

Keep waiting…

Waiting for support answer.

@noris, this time I try mentioning someone in my post.

@noris, problem still occurs as almost every day.

Start playback on chromecast endpoint triggers a Roon Server crash/reboot.

Hello @AdZero ,

First, let me offer sincere apologies that we have taken so long to reply to your message. Our recent launch generated an overwhelming response, and we’ve been working urgently to catch up with the additional volume of requests. That’s no excuse, of course, but I did want to give you some context for the excessive delay.

Can you please reproduce this issue and let me know the exact local time + date + track affected? I would like to take a look at your ROCK logs to see if there are any additional clues surrounding the time of the error.

If you try to use any other Roon Remotes, does the same error occur when you start playback or does only the NVidia Sheild trigger this behavior? Are you running the latest version of the Roon app on the NVidia Sheild?

Hello @noris,

As the problem occured once again, I’m able to answer some of your questions.

I hit the play button on my Android remote today (04/12/2021) at 10:51 (local time which is GMT+2).
The Roon Server restarted as always just after the message “Starting playback…” appeared on the remote". The track played was “Prologue by The Receiving End of Sirens”.

I watched the logs and I didn’t find anything that looks like an error message.

The last line of the file are :

04/12 08:51:34 Trace: [tidal/http] GET => Success
04/12 08:51:34 Trace: [tidal/http] GET => Success
04/12 08:51:34 Trace: [tidal/http] GET => Success
04/12 08:51:34 Trace: [tidal/http] GET => Success
04/12 08:51:34 Info: [SHIELD] [zoneplayer] Playing:
04/12 08:51:34 Info: [SHIELD] [zoneplayer] Queueing:
04/12 08:51:34 Trace: [roonapi] [apiclient 192.168.XXX.XXX:56506] GOT com.roonlabs.image:1/get_image_features {"image_key":"7ae0830e5c37109a9d749bf028bca0c8","format":"image/png","scale":"fit","constrain_width":0,"constrain_height":0}

Then a new log file has been created with :

04/12 08:51:36 Info: Starting RoonServer v1.8 (build 783) stable on linuxx64
04/12 08:51:36 Trace: Checking if we are already running
04/12 08:51:36 Warn: get lock file path: /tmp/.rnsems0-roon
04/12 08:51:36 Trace: Nope, we are the only one running
04/12 08:51:36 Info: Is 64 bit? True
04/12 08:51:36 Info: Command Line Argument: -watchdogport=43085
04/12 08:51:36 Trace: [realtime] fetching time from NTP server
04/12 08:51:36 Trace: [orbit] init seq=7593, pending=367, spcount=11, uidcount=2
04/12 08:51:36 Info: [broker] starting b86fcd12-05e8-47fc-8b44-0be93c77cd21

I tried using the Roon App on my Windows 10 PC after the crash and I was able to launch playback. It’s not surprising as I never experienced two consecutives crashes.

Everything is up to date (Roon Server, Roon OS and Android app), but I wasn’t aware of a Shield app. Shield is only my endpoint used through Chromecast. Anyway, all my android TV are up to date on the Shield.

@noris, any update or question about my problem ?

Let me know how I can help.

Hello @AdZero ,

Apologies for the delay here. Looking over the log snippets you posted above yield no new info, unfortunately.

By this test, I meant what happens if you use the Windows 10 PC to start playback first thing in the morning, does the Core connection still drop, or does that only impact the Android remote? When the Android drops, does the Windows 10 connection drop as well?

Do you by any chance still have these log files? Can you please send me a set via Dropbox / Google Drive / etc. If you don’t have any of these services, just let me know and I can provide alternate upload instructions, thanks!

@noris, sorry for the delay.

I have no time available currently to deal with these problems. The only thing I can say is that the problem still occurs every time I launch playback for the first time on Chromecast endpoint.

I’ll give you some log files when I’ll recover some free time.

Thank you.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.