Roon Core terminates if started using a Remote Desktop Client to a headless W10 system

Roon Core Machine

Windows 10 Pro, 32GB with 2 SSDs and 4 Harddrives
No other applications running on this as it’s a spare machine

Networking Gear & Setup Details

N/A in this situation but everything is connected via Gigabit Ethernet in a 19" rack

Connected Audio Devices

Another Windows 10 machine with external DAC
Various iPads
4 Sonos devices
Raspberry Pi feeding USB Arcam DAC into a Quad pre-amp
Raspberry Pi with Hifiberry Dac into powered monitors

Number of Tracks in Library


Description of Issue

This problem has appeared since moving to 1.8.

The Roon Core is running on a headless Windows 10 System. I normally manage my W10 machines (3 of them) from the RD Client on an iPad. This worked perfectly for my Roon Core machine (I only run Roon, and the occasional backup app, on it) but now Roon terminates shortly after I disconnect the RD Client session from the W10 machine. If I leave the RD session permanently connected the the Roon Core continues to run.

If I connect a monitor/keyboard/mouse to the headless machine and start Roon Core it doesn’t terminate UNTIL I later connect/disconnect using the RD Client.

I assume this may be a graphics driver issue. But, as I mention above, this didn’t happen under 1.7.

I’m not sure about remote desktop from an ipad but I seem to remember there being an issue with open gl versions. I think teamviewer was suggested as an alternative.

1 Like

It appears that there are many TeamViewer users who are being pinged as “commercial users” of TeamViewer when they run a server or “server software” (such as Plex). I don’t really want to buy a product considering I have a product that runs with every other application on my windows systems. It’s only Roon which terminates and given that it worked previously it would appear to be a defect.

I had the same problem this morning, similar win11 headless core setup, rebooted and no problems since.
FTR I have found RD client unpredictable at times and moved to VNC which been rock solid for months.

1 Like

The problem with VNC is that it’s a cloud based solution which seems to be rather an obtuse method of connecting devices which are all on the same ip-subnet within my house.

As for RD Connect - there was a poor release a few years ago which stopped everything working for a while …. iirc it was due to an Apple security update. I haven’t experienced any problems for several years and use it many times a day every day of the year. I even do a lot of preliminary Lightroom, Photoshop and Resolve importing and rough-editing remotely via RD Connect before I move to the PC to do the detailed work. These 3 applications are fairly “graphically intense” and they work OK.

As I understand it (& I may have got it wrong) VNC has cloud access for remote (Non-Lan) access but within the Lan the connection is direct. While access via the cloud is an option it is user definable.


Is the Roon Core the full version (with GUI) or the server version?

If the former, have you considered switching to Server version as it does not have any graphics dependencies.

1 Like

Sorry about the delay in getting back but I was banned from using “devices” over Christmas - which was rather a nice intermezzo.

I’ve solved my problem by adding Roon to the Windows System Startup Folder which ensures that Roon is always started before I connect to the headless system. I assume the Graphics Driver used at that point is a different one from the associated with the Microsoft Desktop App when it connects. As Roon is already started when I connect I don’t get an abend in Roon.

I guess the underlying problem still exists but anyone reading this thread should hopefully know how to bypass the problem. For the uninitiated here’s an example:

First run the command “shell:startup” to determine where your startup folder is. This then opens a File Explorer window at you startup folder. Copy the Roon Shortcut into this folder, thus:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.