Roon Core unseen after changing to Eero WiFi [Resolved - Eero bridge setting]

@support - I have seen a few reports of Core becoming invisible to clients after folks have moved to Eero. Are there any common troubleshooting steps or solutions yet? I’m opening a ticket with Eero support as well.
Describe Your Setup
1) Latest version of Roon installed: 1.5 (build 334) 64 bit.
2) Windows 10 Pro: Version 1803 Build 17134.167
3) Roon Core runs on a Dell Precision 3620. Music is stored there as well.
4) Collection size is roughly 26,000 tracks

1) New Eero Pro setup: two base stations - one connects to ISP’s Arris modem, the other is downstairs using WiFi backhaul. Eeros updated to latest firmware build upon connection.
2) Default settings accepted, except for two Beta features enabled: Local DNS Caching and Smart Queue Management. I have also tried with these settings disabled. Band Steering feature is currently disabled, though I have tried both of these settings as well.

Key issue
None of the Android clients can see Roon Core, nor can Roon Core see them as zones or endpoints. Hardwired devices like my Hifiberry and AV Receiver can be seen by Core. Android devices connected without issue before introducing Eero to the environment.

Troubleshooting to date
I have reset both Eero base stations (power cycle) as well as the Arris modem. I have rebooted the Dell Precision. I have rebooted the Android clients. I have uninstalled and reinstalled Roon app on the Android devices. I have uninstalled and reinstalled Roon Core on Dell Precision.

Thanks, austingonzo

Hey @David_Mathias — Thank you for the detailed report!

How is the Core machine connected to the network? Via WiFi or Ethernet? If Ethernet, what device is it connected to?

Can you confirm if there is any active firewall on the Core machine? If you temporarily disable the firewall is there any change in behavior?

In the router’s settings, are there any settings related to IGMP Snooping or mutlicast? If so, can you share a screenshot of what those settings are?

If you temporarily take one of the stations offline do you still see this behavior?


Hi @dylan,

Core machine is connected with Ethernet to the Arris modem/router.

Core machine has Windows Firewall enabled. (Network is set to Private Network, btw.) Disabling the Firewall temporarily seems to make no difference.

Within the Arris modem/router, there is another firewall setting, NAT is enabled and DNS Relay is disabled. I tested turning DNS Relay on with no effect. Temporarily disabling the firewall in the modem/router had no effect. I took the (downstairs) Eero offline, but Roon would not connect.

Within the Arris DG2470 (model) there are no settings related to IGMP Snooping or mutlicast.

Thanks, austingonzo

Thanks for the details, @David_Mathias.

On one of the remote devices, can you try installing a network scanner, such as FING? Apps like FING will scan your network and show what devices are connected. What we want to test here is whether or not the remote devices can see the Core machine. Please give this a try and let me know:

Before introducing the Eero devices, was this Arris device being used as your router? Does it still have WiFi enabled? If so, and you temporarily connect a remote back to the Arris instead, are you able to connect to the Core?


@dylan, do you need a network topology map, or something similar?

Yes, the Arris is the ISP-issued device. It has routing, WiFi and modem capabilities. I had a T-Mobile-branded Asus N56U in place for wired and WiFi routing up until a month ago. Since T-Mo no longer pushed firmware updates, I decided it had to go. So, I was only using the Arris natively for all features for a month or so before the lousy performance made me seek out alternatives.

I can test turning off the eeros and turning Arris WiFi back on temporarily to see if connectivity is restored.

Thanks, austingonzo

OK - I figured it out. Not sure why this makes a difference, but it did. The eero base station has two ethernet jacks on the back. One was plugged into the Arris router and the other I had connected to my work laptop (which VPNs into the corporate network). I noticed that eero saw that device, but not the Dell Precision (running Roon Core). I moved the cable for the laptop over to the Arris and moved the cable for the Precision (with Core) over to the back of the eero. The Precision suddenly showed up on the eero monitoring tools and I was able to reach Core from the Android devices.

However, when I do that, the hardwired devices running from the router to the AV center (including AV receiver and HiFiBerry) are no longer visible to Core. This won’t be an acceptable outcome either, so I may need to return the eeros for another solution or replace the Arris with another solution.


I think I’ll also reach out to eero Support separately. I know they market a bundle package with a similar Arris modem as part of the package. They’re local to Austin anyway, so hopefully the support experience will be relatively painless.

I’m on hold with Support, but I found this page at eero’s site. It’s looking like using the eero will require setting bridging within the Arris and potentially securing a separate Gigabit Ethernet switch. If so, what was already an expensive mesh network will become even more expensive to run. I may decide to return it in favor of an overwhelmingly powerful all-in-one router with gigabit and wifi that can cover my entire 1800+ square feet of home.

I’ll let you know what I find out.

Thanks, austingonzo

OK - after speaking with eero Support, here’s the solution. Within the eero app, go to the hamburger menu. Select “Network Settings”, go to “Advanced Settings”, go to “DHCP & NAT”, change default setting (Automatic) to “Bridge”. Let the eero register the changes and reboot. When it comes up, the eero will see the Arris router/modem as a device on the network, as well as the system running Roon Core.

The Roon app can now see both hardwired devices and Android phones as endpoints and controls.

(users should understand that they lose some advanced functionality with the eeros with this solution, including options that were available under eero Labs as “Beta” features.)

I hope this helps other Roon users. Please mark this as SOLVED @dylan.

Best, austingonzo.

1 Like

Thanks for sharing your solution with us, @David_Mathias. I’m glad to hear that you were able to get this resolved. If you ever have any questions please feel free to reach out.

Happy listening!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.