Roon core version 1.8 (build 931) stable (64bit) does not upgrade

Roon Core Machine

Windows 11 pro 64-bit version 21H2 build 22000.675
Windows Feature Experience Pack 1000.22000.675.0
AMD Ryzen 7 3700X 8-Core Processor 433 GHz
32.0 GB installed ram

Networking Gear & Setup Details

tp-link DECCO

Connected Audio Devices

USB AudioQuest DragonFly Red
I have Chromecast but have never tried to use it with Roon

Number of Tracks in Library

58,118 Albums
925,821 tracks

Description of Issue

Does not up grade. After running upgrade as usual, Roon shortcut cannot find roon.exe. Work around is to find roon.exe_old in “C:\Users\alree\AppData\Local\Roon\Application” and rename it to roon.exe. Alas upgrade is not installed.

Perhaps just download the latest version from

When I open the latest version from I get the following message.
“The application was unable to start correctly (0x000007b)”

Hmm thats a windows DLL or infrastructure error.

You might try installing the latest .net and see if that helps resolve the issue.

Installed “2022-05 Cumulative Update for .NET Framework 3.5 and 4.8 for Windows 11 for x64 (KB5013628)” and “2022-05 Cumulative Update for Windows 11 for x64-based Systems (KB5013943)” today before experiencing all I have described above.
This has been going on for 3-4 weeks. However long this ,I’m assuming latest, up grade has been available.

I would like to avoid a complete uninstall with Revo Uninstaller Pro and a fresh install. I think I would have to physically remove my Library (tracks) and reinstall roon core.

I have used my work around for several weeks and can continue. Just spit

I have uninstalled Roon server. I am trying a fresh install but alas no joy. Downloaded latest Server but get the same “The application was unable to start correctly (0x000007b)” error message. What do I do with “Hmm thats a windows DLL or infrastructure error.”?

Help please.

I have no access to roon currently.

Can I call someone?

I would Google that error code and try to solve your Windows issue with some of the posted solutions.

1 Like

Restoro will not run. Uninstalled all Microsoft C++ Redistributable. Installed new vcredist_x64 & vcredist_x86.
Alas no joy. Still get 0x000007b error when installing RoonInstaller64 or RoonServerInstaller64.

Is this the only way to contact tech support for Roon? Who wrote Roon? What is it written in?

Has any one re-installed win 11 and solved my problem? I would hate to go through a re-install and find out it was something else.

Hey @Al_Reeder,

Sorry to hear about your issues with trying to install the latest build.

Ultimately, this is an underlying issue with your Windows installation. It’s not an issue with Roon, but rather an issue with some dependency that the Windows installer is looking for.

You may want to ensure that you have Visual C++ redistributable installed and, if so, then uninstall, reboot, and re-install. Can you please verify that you’re on the latest version of .NET, and don’t have previous copies (2.0, 2.1, 3.0, 3.5, 4.1, etc) installed?

If that doesn’t work you’re going to need to contact Microsoft for support on this one, hopefully the error code is something they’ve seen and have experience with.

To answer your question regarding an OS reinstall, we have seen cases where that remedied the issues.

All is well. Thanks to the group for all the ideas. Ended up reinstalling Windows 11. It had been almost 4 yrs.


Hi @Al_Reeder

Thank you for the update, I’m happy to hear that an OS reinstall cleared up your issue.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.