Roon Core will not login after reinstall of windows

Core Machine (Operating system/System info/Roon build number)

Windows 10 1903 Build 18362.175 - Asus Maximus Gene V, Intel i7-3770K, 16GB RAM - Roon1.6 (build 416)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Intel I350-T2 NIC Ethernet - Netgear JGS524E Switch - Media stored on a Synology DS713+ Both NIC and NAS are wired using static link aggregation.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

iFi Nano iDSD Black Label through USB

Description Of Issue

After reinstalling Windows and Roon. Roon will allow me to enter my login information but then hangs without doing anything other than displaying the animated Roon logo. I completely uninstalled and reinstalled Roon twice and got the same result. I use Malwarebytes and Windows Defender, disabled both of those and still same result.

Hi @Thomas_Cora,

You mentioned here that you uninstalled, but can you please try setting the old database aside to see if it will help? You can use the following instructions to do so:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Verify if the issue still occurs

If the issue is happening after this please let me know and we can proceed with other troubleshooting.

Hi Noris,

Thanks for the prompt reply. I followed your instructions of renaming the Roon folder and reinstalled. I did verify that it did create a new Roon folder, while the Roon_old still being there. Unfortunately, I get the same result. Any more help you can give is greatly appreciated.


Tom Cora

Hi @Tomas_Cora,

Thanks for giving that a try. Next, I would suggest that you bypass the switch by trying to connect the Core directly to the router (via Ethernet) and also verify that Roon.exe and RAATServer.exe have been added to your Windows firewall and any other Antivirus firewalls that may be present. You can find the link to the executable files by navigating to the Database Location/Application path. Can you give that a try next?

– Noris

Hey Noris,

I didn’t follow your instructions exactly. What I did was delete my virtual teamed network card and disabled link aggregation in my switch. It worked, Roon is now asking me to add my music. Now, my dilemma is, I don’t want to keep this setup, my NAS is in link aggregation mode and there are obvious benefits when accessing files from it. Is there something I can adjust in Roon after I get it setup, so that I can go back to lag?




Everything seems to be good. I just went and recreated my virtual nic and enabled lag on the switch, rebooted everything and opened Roon. It now works. Thanks for your time, I appreciate it.

Take Care,


Hi @Tomas_Cora,

Glad to hear that the issue is resolved after disabling the network cards and re-enabling them!

Just so you are aware, we have seen a few reports surrounding link aggregation on NAS, if you do experience similar behavior I would try to disable this aspect as a troubleshooting step as it might be related.

Either way, glad to hear that you are back up and running with those changes and I hope you have a continued great Roon experience!

– Noris

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.