Roon Core won’t install or update on M1 iMac from Roon Web page

Roon Core Machine

2021 Apple M1 24-inch iMac running macOS 12.6

Networking Gear & Setup Details

T-Mobile Internet with integrated WiFi, no VPN

Connected Audio Devices

Using Bluesound NODE connected via WiFi

Number of Tracks in Library

Zero, I only stream via Qobuz

Description of Issue

I love the sound via Roon, it is simply the BEST. But, I hate how poorly it runs on my iMac. My iMac is a 2021, 24-inch, M1 running Monterey Version 12.6.

ISSUE #1- Can’t Update Software
I just loaded 2.0 (build 1128) and when I go to Settings->About it downloads new software and then gives the “There was an error checking for update” message. This happened immediately after loading the new 2.0 software.

This was happening ALL the time when I was on 1.8. You told me previously to delete the app from the dock and from the Applications folder, and then change the name of Roon folder in the Library folder to “Roon_old” and then reboot the computer and then download new software. This never fixed the problem. Now I’m on 2.0 (see 2.0 installation issue #2 below for how I even got 2.0 on the iMac), and I am getting the SAME error message with this software version.

Please advise how I can get Roon to update its software properly?

ISSUE #2 - Installation of 2.0
I could not get my iMac to install 2.0 directly from your site. I tried four times deleting and renaming all the files as outlined above, and it kept installing 1.8. It was like your site thought I wanted 1.8 even though I was on the 2.0 download page. I thought, “Maybe there is some hidden file on my Mac that is confusing your site.” So, I tried eliminating my iMac from the equation.

I downloaded 2.0 on a virgin (no Roon software) Mac Laptop Pro with Intel processor using the same Roon page I was using with my iMac. Voila, it loaded 2.0 correctly the very first FIRST TIME. Why does 2.0 load on a virgin computer, but not on my M1 iMac that was already running Roon?

Next, I copied the known good 2.0 download file to a thumb drive, and copied the known good 2.0 file to my iMac, and it installed 2.0 correctly (except see Issue #3 below).

Why does the M1 iMac NOT download the correct file (tried four times), but a virgin Intel Mac Pro laptop without any Roon software download the correct file just fine?

What is the problem downloading software from your site onto my M1 iMac? This is happening over and over. It happened with 1.8 and again with 2.0.

I have never had ANY software program that was as problematic as Roon. If it didn’t sound so good on my stereo, I would dump it, but it is the best sounding method for streaming Qobuz. However, I’m getting near the end of my patience.

ISSUE #3 - After Installation of 2.0, all my playlists and tags are GONE!
After installing 2.0, all my playlists are gone. Where are they and how do I get them back?

ISSUE #4 - Roon Core seems to “lose” the Bluesound NODE from the audio list if I don’t use Roon for several days. This happened all the time with 1.8, and it is happening again with 2.0. Sometimes I just reload the Roon client on the iPad and that might fix it. If not, I reboot the Bluesound NODE and sometimes that fixes the problem. If not, I have to go to the iMac and QUIT the Roon app, and then restart it, and that always works.

What does the Roon core “lose” the Bluesound NODE from the audio list after a few days?

You know, with Apple, everything just works. I love it for that!!

With Roon, NOTHING ever works the first time on my M1 iMac, and every time something changes, things don’t work AGAIN!!

I know Roon is a small company and you are doing state-of-the-art things with streaming, but you really need to do better. Software needs to load correctly the first time without all kinds of manual effort, and playlists can’t just disappear whenever new software is loaded. Items on audio lists can’t just disappear for no reason! This is unacceptable!!! I feel like I’m testing alpha software that is full of bugs, and I’m paying a monthly fee to do that!

Please help!! I would really like this to just work!

Frustrated Mike

Hey @Rose_Hosta,

You have my sincerest apologies for the delayed response here, we’ve been dealing with a higher-than-usual volume following our release and we’re working as quickly as we can to get back to everyone.

Following up on this thread, I was able to take a look at your account and I see the iMac is now running 2.0. From what you’ve mentioned above, there seems to be some sort of auto-redirection when attempting to upgrade from 1.8 to 2.0. Unfortunately, your machine is not online and hasn’t been online in the last few days, so I’m not able to enable diagnostics to take a deeper look.

If possible, please get your core and roon up and running so we can enable diagnostics :+1:

If you did a fresh install of Roon, chances are you’ll need to load or restore from a backup in order to load your custom settings and playlists. You can learn more about that here:

You mention that the node is connected via wifi. No matter how strong the wifi connection may be, it can still cause hiccups when working with higher-quality audio playback. If possible, can you please test hardwiring your node to your core, and see if your issue persists?

I’ll be on standby for your reply :+1:


Roon Core up and running on my iMac now. What next?

Regarding Issue #4 about losing the Bluesound NODE from Roon audio list. The issue is NOT bandwidth or a WiFi problem. EVERY time this happens I switch over to my Bluesound app on the iPad and the Bluesound NODE works just fine via WiFi. Bluesound sees the node and 196/24 files play just fine without any bandwidth problem. When I switch back to Roon, it can’t see the NODE. Why is that? The problem is something with Roon, not with my WiFi or bandwidth. The problem is with Roon. When I reload the Roon core on the iMac, the Bluesound NODE magically reappears on the same WiFi network.

Please advise.

Hey @Rose_Hosta,

After taking a look at the current firmware version for the node (3.20.25) it looks like you’ll need to update this.

A good thing to note here, Bluesound works with Roon to implement RAAT and the communication between Roon and BlueOS is based on that implementation, which is different than how it connects with other software and devices like your iPad and the bluesound app. Both your devices should be updated.

You can check out more info here: and release notes are on the same page :+1:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.