Roon Core won’t recognize my KEF LS50W

Roon Core Machine

iMac connect via Ethernet to eero mesh.

Networking Gear & Setup Details

Eero mesh network.

Connected Audio Devices

KEF LS50W is WiFi only

Number of Tracks in Library

2000 tracks

Description of Issue

Trying to figure out why my Roon core (iMac) won’t recognize my KEF LS50W.

When I try to play music to my speakers, it plays via the iMac speakers. I can turn the speaker on with the KEF connect app but I cannot turn it off (so weird!). I get this message below…

I have a eero mesh network. The iMac is connected via Ethernet and the speaker is WiFi.


You have looked to see if they show up in Settings / Audio? You have to enable them in Roon first before Roon will see them. Then they should show up in the zone picker as zone to choose to play to.

If they don’t show up in audio settings then then the most probable cause is a misconfigured network , where your wired network and WiFi network are acting as two different subnets. Check your core and kek speakers IP addresses to see if they are on the same network. The first 3 sets of numbers must be the same if not then that’s your issue.

If all on same network then power down network gear and your core and legs. Restart network gear then turn on core when up and running power on Kef’s.

If no joy speak to your dealer.

1 Like

That looks like a KEF connection issue to me. Have you updated the firmware from the stock firmware? In my experience the initial KEF wireless is flaky at best, even after improvements with the latest firmware it still bugs out ever once in a while.

I went wired to the KEF and “most” of the issues went away.

Even better is to feed the KEF with a different endpoint and not use its network abilities. I use a RPi with Ropieee and it works very well. All wired in my case.

Thanks for the suggestion. It’s the same initial stock firmware. Not sure how to update but I’ll look for it online.

Hello @Thuan_Le ,

Can you please share a screenshot of your Roon Settings → Audio tab? Do you have the KEF zone enabled?

Hello. Yes. The one I disabled doesn’t work. It just sends the sound to my iMac.

I just got the one I enabled to work after resetting KEF speakers and reinstalling the KEF connect. But I have no control over volume on my iPhone. Everything was working fine on my mesh until a couple months ago…not sure what happened.


Hi @Thuan_Le ,

It looks like you have your LS50s enabled under Roon Tested, but you have a different zone selected. Next to the volume icon, you have a sofa icon, please click that, then select the LS50W zone and try to play something to it. Does that work?

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.