Roon core won't connect to ARC

Roon Core Machine

iMac (21.5-inch, Late 2013)
3.1 GHz Quad-Core Intel Core i7
16 GB 1600 MHz DDR3

Networking Gear & Setup Details

Connected by ethernet to Draytek Vigor 2862 router

Connected Audio Devices

All devices (several streamers) connected by ethernet

Number of Tracks in Library

About 10,000 tracks I think

Description of Issue

Have downloaded Roon 2.0 but the port forwarding doesn’t work. I get this error message

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“status”:“NotFound”}

I have gone into my router’s settings and enabled UpNP but it doesn’t seem to make any difference. Any help appreciated - thanks!

Need more info. Who is your ISP. What other gear is in your network? What’s connected to what?

1 Like

Hey @Josh_Raymond,

Ben here with the support team, I wanted to follow up to see if you’re still running into issues getting Arc setup?

Per @ipeverywhere’s reply, it would be very helpful to have more information on your ISP, and more details around your network setup.

Typically, errors like the one you see can be caused by a misconfigured Port Forwarding setting, if you are not seeing Ready listed in Roon Settings -> Roon ARC, please look over this guide before proceeding.

If you have reviewed this guide and still have not resolved the issue, can you provide the following details about your network setup to help expedite troubleshooting?

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  5. How is your Roon Core connected to the internet?


Hi there,

Sorry for taking so long to reply! I have read the guide and managed to configure my router to use UPnP. It still doesn’t work so I think I need to set up manual port forwarding. The problem is don’t know how to ensure my core uses the same IP address, nor how to configure a new port forwarding rule in my router. To put this in perspective the UPnP activation was the first time I have ever gone into my router’s settings. I didn’t even know it had them.

Answers to your questions

  1. My internet service provider is Spitfire Internet

  2. My router is a Draytek Vigor 2862

  3. I have an additional network switch - an sNH-10G - with a DOT fibreoptic kit. This switch connects via ethernet to all my music players, but not to my Roon Core as this is my desktop computer.

  4. I sometimes use a VPN but have made sure this has been switched off when I have been trying to connect to Roon ARC.

  5. My Roon Core is connected to the network via ethernet.

Thanks and best wishes,


1 Like

Hey @Josh_Raymond,

No worries at all! I’d be curious to see if this thread of another user with the same router would help you:

I would also be curious to test your system with your switch removed temporarily from your line (or at least make sure your core is hardwired directly to your router bypassing the switch.) But, give the above thread a try first and let me know :+1:

Hi Benjamin,

Setting it up manually according to those instructions has worked - thank you!

Best wishes,


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.