Roon Core won't start after PC reboot

(Mani Sandher) #1

Core Machine (Operating system/System info/Roon build number)

Windows 10, latest build)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

iFi Nano

Description Of Issue

I’ve had a few problems with Roon Core recently due to network problems and a power cut yesterday. Installed Roon Core from scratch again, which worked perfectly. But now Roon Core refuses to start post a PC reboot.

Here are the logs:

Would appreciate any help.

Cheers, Mani.

(Noris) #2

Hi @Mani_Sandher,

Can you please provide some more info here on how exactly Roon refuses to start? Are you seeing any error messages or does the Roon app show up but not display anything?

I took a look at the logs you uploaded and I’m not seeing anything in particular regarding them so a bit of clarification on the exact error state would be appreciated.

– Noris

(Mani Sandher) #4

Hi Norris,

Absolutely nothing happens when I click on the Roon shortcut on my desktop, or on the application itself (AppData\Local\Roon\Application\Roon.exe).

I’ve just tried a fresh install of Roon, and still, nothing happens. It was working perfectly yesterday, and all that has happened since then is a server reboot.

Anything come to mind?

Mani.

(Mani Sandher) #5

W10 disk check found errors on the drive, probably due to the power cut I had a few days ago, causing my original Roon database to get corrupted.

I’m attempting to repair the errors, after which I hope Roon Core will start working normally again.

Lessons learned:

  1. do Roon backups regularly
  2. power the server off a UPS

Mani.

(Mani Sandher) #6

Disk Check found no errors on the drive.

I’ve uninstalled and reinstalled Roon Core from fresh (again) and yet it still refuses to launch. I double click on its icon and absolutely nothing happens.

Could there be something still lurking in the registry from the original Roon Core install (which worked perfectly for years BTW) that I need to clean out?

Any other ideas? I really can’t live without music for too long :cold_sweat:

(All other programs/apps on the server are working perfectly.)

Mani.

(Ged) #7

Try installing the 32 bit version as that might get you going whilst you wait for help with the main install problem…

(Mani Sandher) #8

Ah OK, thanks. I’ll give it a go later today if no other ideas pop up by then.

Mani.

(Ged) #9

Wow, that was quick!
I had the same problem but only on the client version and I installed the 32bit version and it’s fine as a front end.
I moved to ROCK as a server just to solve this sort of W10 issues :slight_smile:

(Mani Sandher) #10

W10’s not at fault on this occasion. I’ve had Roon Core working fine for a few years on my W10 server. Our builders tripped a fuse the other day and that’s when all the problems started.

Thanks for the heads-up on trying the 32bit version.

Mani.

(Noris) #11

Hi @Mani_Sandher,

How exactly did you reinstall Roon and start fresh? Was it just through Window’s Apps & Programs? I would like to try setting the old database aside as well as this might help. To do so you’ll need to:

  • Exit out of Roon
  • Navigate to your Roon’s Database Location: https://kb.roonlabs.com/Database_Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/reinstall the Roon App to generate a new Roon folder

Do let me know if that helps!

– Noris

(Mani Sandher) #12

No. This was the first thing I tried. Since then, I’ve tried uninstalling Roon completely and starting afresh.

I’m no expert, but seems that there must be something remaining in the Registry that needs clearing out. Any ideas?

Mani.

(Noris) #13

Hi @Mani_Sandher,

You can give the 32-bit version of Roon a try, after performing the reinstall please reboot the Core once more and upload a new set of diagnostics for review.

I will also be reaching out to our QA team to ask them to take a closer look at this case, I will be sure to reach out to you once I hear back from them.

– Noris

(Edmund Comber) #14

@Mani_Sandher … as it is Windows 10 and you feel leftover Registry entries might be an issue, you could try installing Revo Uninstaller (free version) and then uninstall Roon through Revo Uninstaller. I have be a user of Revo Uninstaller for many years, initially the free version, and now the paid for Pro version. It will allow you to delete all leftover Registry and files, I never uninstall anything without it.

The reboot the PC and try reinstalling Roon again…

(Mani Sandher) #15

Hi Edmund, I’ve just tried Revo Uninstaller and think it’s great. Unfortunately, it didn’t solve the problem. Thanks for recommending it though.

Mani.

(Mani Sandher) #16

No, the 32-bit Roon version doesn’t work either. I think my W10 is more corrupted due to the power cut than I had originally thought. Windows Updates aren’t working either. I think the only real solution is to repair it properly, by resetting it.

Thanks for all the suggestions though.

Mani.

(Edmund Comber) #17

Hi Mani

Yes I agree, a complete fresh install of Windows 10 is probably the best way forward. Good luck.

(Noris) #18

Hi @Mani_Sandher,

I received some feedback from the QA team regarding your case. There are two ways that we can proceed here:

  1. You try to reinstall the operating system or restore it from an earlier point in time (recommended)

  2. We take a look at the Windows Event Viewer logs to see if there is perhaps any info contained about the issue there when you start the Roon App.

If Windows Updates are not working either, I would agree with you here in thinking the power cut triggered an issue with the operating system itself, and that the system itself should be repaired first. Do let us know how you would like to proceed.

– Noris

(Mani Sandher) #19

Just to wrap this one up…

Having tried a whole host of things, it became obvious that the power cut a few weeks ago must have physically damaged the SSD that W10 and Roon Core resided on. Check disk wouldn’t work, I couldn’t repair W10… couldn’t even do a fresh install.

I therefore decided to buy a new SSD and do a fresh install on that. It’s all done now, and everything works perfectly. (One up side is that the new M.2 SSD is a lot faster than my old SATA SSD.)

It was an expensive lesson (in time more than money) and one I won’t be making again - I’m now powering the server from a UPS and will make regular Roon backups from here on in.

Thanks to those of you who made suggestions.

Cheers, Mani.

1 Like
(Noris) #20

Hi @Mani_Sandher,

Thanks for the update and glad to hear that replacing the SSD drive resolved the issue! I hope you have a continued enjoyable Roon experience!

– Noris

(system) closed #21

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.